aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch
diff options
context:
space:
mode:
authorGabriel Barbu <gabriel.barbu@enea.com>2013-07-25 15:28:33 +0200
committerSaul Wold <sgw@linux.intel.com>2013-07-27 23:28:28 -0700
commit6e2d8724b023e2b6b55db7845009b4422a53c3b3 (patch)
treeb65f031a4c02f44d296b3d74fc9ca8fc0b1c8b2d /meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch
parent6ac10e7d122323618aa10f14fd807b6ae7c2477a (diff)
downloadopenembedded-core-contrib-6e2d8724b023e2b6b55db7845009b4422a53c3b3.tar.gz
strace: Add ptest
Install strace test suite and run it as ptest. Signed-off-by: Gabriel Barbu <gabriel.barbu@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch')
-rw-r--r--meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch b/meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch
new file mode 100644
index 0000000000..f5556b23e3
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch
@@ -0,0 +1,28 @@
+strace: Add ptest
+
+Signed-off-by: Gabriel Barbu <gabriel.barbu@enea.com>
+Upstream-Status: Pending
+
+--- old/tests/Makefile.am 2013-07-23 13:44:24.660481381 +0200
++++ new/tests/Makefile.am 2013-07-23 16:22:42.937654391 +0200
+@@ -9,3 +9,20 @@
+ EXTRA_DIST = init.sh $(TESTS)
+
+ CLEANFILES = check.log
++
++buildtest-TESTS: $(check_PROGRAMS) $(TESTS)
++
++install-ptest:
++ install $(BUILDDIR)/strace $(DESTDIR)
++ install "$(srcdir)/.."/strace-log-merge $(DESTDIR)
++ install -d $(DESTDIR)/$(TESTDIR)
++ cp $(BUILDDIR)/$(TESTDIR)/Makefile $(DESTDIR)/$(TESTDIR)
++ sed -i -e 's/^Makefile:/_Makefile:/' $(DESTDIR)/$(TESTDIR)/Makefile
++ for file in $(check_PROGRAMS); do \
++ install $(BUILDDIR)/$(TESTDIR)/$$file $(DESTDIR)/$(TESTDIR); \
++ done
++ for file in $(EXTRA_DIST); do \
++ install $(srcdir)/$$file $(DESTDIR)/$(TESTDIR); \
++ sed -i -e 's/$${srcdir=.}/./g' $(DESTDIR)/$(TESTDIR)/$$file; \
++ done
++ sed -i -e 's/$$srcdir/./g' $(DESTDIR)/$(TESTDIR)/net