aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-07-15 13:24:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-17 12:28:08 +0100
commit518d6b32aa9d84e572ccd6d04368f4c5bdb222ec (patch)
tree8762deebb9bddadd8346fb7a33fdb8f163ede720 /meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
parent5a16da19eda60992e094b38ebb185875529b3b4c (diff)
downloadopenembedded-core-contrib-518d6b32aa9d84e572ccd6d04368f4c5bdb222ec.tar.gz
squashfs-tools: Upgrade to 4.3
Remove patches that are now implemented upstream COPYING file has formating change no change to licence itself Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb')
-rw-r--r--meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
new file mode 100644
index 0000000000..e0c69ab127
--- /dev/null
+++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
@@ -0,0 +1,38 @@
+# Note, we can probably remove the lzma option as it has be replaced with xz,
+# and I don't think the kernel supports it any more.
+SUMMARY = "Tools for manipulating SquashFS filesystems"
+SECTION = "base"
+LICENSE = "GPL-2 & PD"
+LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://../../7zC.txt;beginline=12;endline=16;md5=2056cd6d919ebc3807602143c7449a7c \
+ "
+DEPENDS = "attr zlib xz"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${PV}.tar.gz;name=squashfs \
+ http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2;name=lzma \
+ "
+
+SRC_URI[squashfs.md5sum] = "d92ab59aabf5173f2a59089531e30dbf"
+SRC_URI[squashfs.sha256sum] = "0d605512437b1eb800b4736791559295ee5f60177e102e4d4ccd0ee241a5f3f6"
+
+SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759"
+SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e"
+
+S = "${WORKDIR}/squashfs${PV}/squashfs-tools"
+
+# EXTRA_OEMAKE is typically: -e MAKEFLAGS=
+# the -e causes problems as CFLAGS is modified in the Makefile, so
+# we redefine EXTRA_OEMAKE here
+EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1"
+
+do_compile() {
+ oe_runmake mksquashfs
+}
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 0755 mksquashfs ${D}${sbindir}/
+}
+
+ARM_INSTRUCTION_SET = "arm"
+
+BBCLASSEXTEND = "native"