aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2014-03-06 14:15:41 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-07 15:04:36 +0000
commitf33555f52a4ee83f0bd205cdf483045fcd0578b2 (patch)
treed6654e186ef1bf2a9738efaa0040c4878c4bd402 /meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
parent1dd9a16030bc2dc673c7b121dea6e78f2681f55e (diff)
downloadopenembedded-core-contrib-f33555f52a4ee83f0bd205cdf483045fcd0578b2.tar.gz
run-postinsts: use it for opkg/dpkg too
Currently, opkg/dpkg have their own postinstalls that create a run-postinsts script which is run at first boot. This commit prepares the run-postinsts recipe/script to be used by opkg/dpkg when DISTRO_FEATURES includes package-management. [YOCTO #5666] Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb')
-rw-r--r--meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
index 64f85c262d..e990c670c0 100644
--- a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
+++ b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
@@ -37,6 +37,8 @@ do_install() {
sed -i -e 's:#SYSCONFDIR#:${sysconfdir}:g' \
-e 's:#SBINDIR#:${sbindir}:g' \
-e 's:#BASE_BINDIR#:${base_bindir}:g' \
+ -e 's:#IMAGE_PKGTYPE#:${IMAGE_PKGTYPE}:g' \
+ -e 's:#PM_INSTALLED#:${@base_contains("IMAGE_FEATURES", "package-management", "true", "false", d)}:g' \
${D}${sbindir}/run-postinsts \
${D}${systemd_unitdir}/system/run-postinsts.service
}