aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby/ruby_2.5.1.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2018-04-09 14:55:07 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 09:54:56 +0100
commit98f889ca4a07c54165d3d983582639951b8ef32e (patch)
treef40b7adf6356105cc48b1f6197d13a043be1f35f /meta/recipes-devtools/ruby/ruby_2.5.1.bb
parentfd5add4fdf777d6fcc89754a46cbc6a94d5eb3fc (diff)
downloadopenembedded-core-contrib-98f889ca4a07c54165d3d983582639951b8ef32e.tar.gz
ruby: upgrade to version 2.5.1
License-Update: Checksum of LEGAL file updated for changes to upstream URL and addition of Wayback Machine url Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.5.1.bb')
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.5.1.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.5.1.bb b/meta/recipes-devtools/ruby/ruby_2.5.1.bb
new file mode 100644
index 0000000000..91048284c1
--- /dev/null
+++ b/meta/recipes-devtools/ruby/ruby_2.5.1.bb
@@ -0,0 +1,49 @@
+require ruby.inc
+
+SRC_URI += " \
+ file://ruby-CVE-2017-9226.patch \
+ file://ruby-CVE-2017-9228.patch \
+ "
+
+SRC_URI[md5sum] = "23867bc8c16c55e43b14dfe0614bcfa8"
+SRC_URI[sha256sum] = "dac81822325b79c3ba9532b048c2123357d3310b2b40024202f360251d9829b1"
+
+# it's unknown to configure script, but then passed to extconf.rb
+# maybe it's not really needed as we're hardcoding the result with
+# 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
+UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
+
+PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
+PACKAGECONFIG[gmp] = "--with-gmp=yes, --with-gmp=no, gmp"
+PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo,"
+
+EXTRA_AUTORECONF += "--exclude=aclocal"
+
+EXTRA_OECONF = "\
+ --disable-versioned-paths \
+ --disable-rpath \
+ --disable-dtrace \
+ --enable-shared \
+ --enable-load-relative \
+"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
+
+SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
+RDEPENDS_${PN}-ri-docs = "${PN}"
+FILES_${PN}-ri-docs += "${datadir}/ri"
+
+SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source"
+RDEPENDS_${PN}-rdoc = "${PN}"
+FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
+
+FILES_${PN} += "${datadir}/rubygems"
+
+BBCLASSEXTEND = "native"