aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-07-02 13:17:18 +0100
committerSaul Wold <sgw@linux.intel.com>2013-07-02 07:58:10 -0700
commitb7c2e01753e4a09388a3282e534bcbd163cd6ef7 (patch)
tree868d69c5d52f9217f6e592f70f5cefcff7b0c1ca /meta/recipes-devtools/rpm
parentff0e863f2d345c42393a14a193f76d699745a2b9 (diff)
downloadopenembedded-core-contrib-b7c2e01753e4a09388a3282e534bcbd163cd6ef7.tar.gz
rpm: add wrapper for debugedit executable
This should fix sstate relocation issues with debugedit failing during do_package on the Yocto Project autobuilder. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.9.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
index 0dd5806026..3f4854eb6a 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.9.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
@@ -472,7 +472,7 @@ do_install_append_class-native() {
RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
- for rpm_binary in ${D}/${libdir}/rpm/bin/rpm*; do
+ for rpm_binary in ${D}/${libdir}/rpm/bin/rpm* ${D}/${libdir}/rpm/bin/debugedit; do
create_wrapper $rpm_binary \
RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \