aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-09-08 17:18:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-14 22:22:07 +0100
commit03fa8209e4ebcf16b2bdf4038e26db31b14e9de0 (patch)
tree6b7610692015c9efb4a8d7a164b61fc6b6b0efb2 /meta/recipes-devtools/rpm
parent059c5568a130f82f8612498487e49f231247b4a5 (diff)
downloadopenembedded-core-contrib-03fa8209e4ebcf16b2bdf4038e26db31b14e9de0.tar.gz
rpm: remove redundant removals
These were noticed by the use of bashisms (rm *.{foo,bar}) and lots of these rm commands are deleting files which don't exist in the first place. (From OE-Core rev: 52182efe70a8fb59b5640cd1cf2bdb55e77c0076) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.16.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.16.bb b/meta/recipes-devtools/rpm/rpm_5.4.16.bb
index 9f78deeea2..dd6e103b22 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.16.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.16.bb
@@ -554,54 +554,20 @@ do_install_append() {
install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh
install -m 0755 ${WORKDIR}/perfile_rpmdeps.sh ${D}/${libdir}/rpm/perfile_rpmdeps.sh
- # Remove unpackaged files (based on list in rpm.spec)
- rm -f ${D}/${libdir}/rpm/{Specfile.pm,cpanflute,cpanflute2,rpmdiff,rpmdiff.cgi,sql.prov,sql.req,tcl.req,trpm}
-
- rm -f ${D}/${mandir}/man8/rpmcache.8*
- rm -f ${D}/${mandir}/man8/rpmgraph.8*
- rm -f ${D}/${mandir}/*/man8/rpmcache.8*
- rm -f ${D}/${mandir}/*/man8/rpmgraph.8*
- rm -rf ${D}/${mandir}/{fr,ko}
-
rm -f ${D}/${includedir}/popt.h
rm -f ${D}/${libdir}/libpopt.*
rm -f ${D}/${libdir}/pkgconfig/popt.pc
rm -f ${D}/${datadir}/locale/*/LC_MESSAGES/popt.mo
rm -f ${D}/${mandir}/man3/popt.3
- rm -f ${D}/${mandir}/man1/xar.1*
- rm -f ${D}/${bindir}/xar
- rm -rf ${D}/${includedir}/xar
- rm -f ${D}/${libdir}/libxar*
-
- rm -f ${D}/${bindir}/lz*
- rm -f ${D}/${bindir}/unlzma
- rm -f ${D}/${bindir}/unxz
- rm -f ${D}/${bindir}/xz*
- rm -rf ${D}/${includedir}/lzma*
- rm -f ${D}/${mandir}/man1/lz*.1
- rm -f ${D}/${libdir}/pkgconfig/liblzma*
-
rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/*.a
rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/*.la
rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/rpm/*.a
rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/rpm/*.la
- #find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \
- # -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
- #find ${D}/${libdir}/perl5 -type d -depth -exec rmdir {} 2>/dev/null ';'
-
rm -f ${D}/${libdir}/rpm/dbconvert.sh
-
rm -f ${D}/${libdir}/rpm/libsqldb.*
- # We don't want, nor need the Mandriva multiarch items
- rm -f ${D}/${bindir}/multiarch-dispatch
- rm -f ${D}/${bindir}/multiarch-platform
- rm -f ${D}/${libdir}/rpm/check-multiarch-files
- rm -f ${D}/${libdir}/rpm/mkmultiarch
- rm -f ${D}/${includedir}/multiarch-dispatch.h
-
rm -f ${D}/${libdir}/rpm/gstreamer.sh
rm -f ${D}/${libdir}/rpm/gem_helper.rb
rm -f ${D}/${libdir}/rpm/rubygems.rb
@@ -610,12 +576,10 @@ do_install_append() {
rm -f ${D}/${libdir}/rpm/macros.d/kernel
rm -f ${D}/${libdir}/rpm/macros.d/gstreamer
rm -f ${D}/${libdir}/rpm/bin/mgo
- rm -f ${D}/${libdir}/rpm/bin/dbconvert
rm -f ${D}/${libdir}/rpm/bin/pom2spec
rm -rf ${D}/var/lib/wdj ${D}/var/cache/wdj
rm -f ${D}/${libdir}/rpm/bin/api-sanity-checker.pl
-
}
do_install_append_class-target() {