summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_4.14.1.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-04-08 15:56:07 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-04-09 12:11:37 +0100
commit815ccef2d5bef1e46c51916e694d0974aee394a9 (patch)
tree7ea76fbb2396617c123a2bcf876b6d061c84ed00 /meta/recipes-devtools/rpm/rpm_4.14.1.bb
parent13a80b22f28b81a0082d181674295a0f96111f6b (diff)
downloadopenembedded-core-contrib-815ccef2d5bef1e46c51916e694d0974aee394a9.tar.gz
rpm: build without dbus for rpm-native
Add option for dbus in configure.ac, and explicitly build without dbus for rpm-native. Previously, the rpm recipe tries to prevent rpm-native from attempting to inhibit shutdown via session dbus by appending '--disable-plugins' to EXTRA_OECONF in case of native. However, some layer may need some functionality via plugin support. And when it enables it, we would meet the following warning at rootfs time. Unable to get systemd shutdown inhibition lock: Socket name too long As plugins/systemd_inhibit.c is the only place that's related to this dependency, we can be sure that dbus is really not needed for rpm-native. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_4.14.1.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.14.1.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.14.1.bb b/meta/recipes-devtools/rpm/rpm_4.14.1.bb
index 7b8ea46a75..818d3ef9e3 100644
--- a/meta/recipes-devtools/rpm/rpm_4.14.1.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.14.1.bb
@@ -40,6 +40,7 @@ SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.14.x \
file://0004-build-pack.c-remove-static-local-variables-from-buil.patch \
file://0001-perl-disable-auto-reqs.patch \
file://0001-Revert-Set-FD_CLOEXEC-on-opened-files-before-exec-fr.patch \
+ file://0001-configure.ac-add-option-for-dbus.patch \
"
PE = "1"
@@ -63,8 +64,9 @@ EXTRA_OECONF_append_libc-musl = " --disable-nls"
#
# --localstatedir prevents rpm from writing its database to native sysroot when building images
#
-# Also disable plugins, so that rpm doesn't attempt to inhibit shutdown via session dbus
-EXTRA_OECONF_append_class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
+# Disable dbus for native, so that rpm doesn't attempt to inhibit shutdown via session dbus even when plugins support is enabled.
+# Also disable plugins by default for native.
+EXTRA_OECONF_append_class-native = " --sysconfdir=/etc --localstatedir=/var --without-dbus --disable-plugins"
BBCLASSEXTEND = "native nativesdk"