summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/repo/repo_2.24.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-05-05 07:05:24 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-05 21:17:13 +0100
commit75dde0e4c9545c5e2df1477ee4f495e431910422 (patch)
tree7a7e9ba2915bf6c561713ff41100ee06b5d118f4 /meta/recipes-devtools/repo/repo_2.24.1.bb
parent3c17d24288bbf8134505c91fb5dccff5f433539d (diff)
downloadopenembedded-core-contrib-75dde0e4c9545c5e2df1477ee4f495e431910422.tar.gz
repo: upgrade 2.23 -> 2.24.1
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/repo/repo_2.24.1.bb')
-rw-r--r--meta/recipes-devtools/repo/repo_2.24.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/repo/repo_2.24.1.bb b/meta/recipes-devtools/repo/repo_2.24.1.bb
new file mode 100644
index 0000000000..f6e1ce730b
--- /dev/null
+++ b/meta/recipes-devtools/repo/repo_2.24.1.bb
@@ -0,0 +1,31 @@
+# SPDX-License-Identifier: MIT
+# Copyright (C) 2021 iris-GmbH infrared & intelligent sensors
+
+SUMMARY = "Tool for managing many Git repositories"
+DESCRIPTION = "Repo is a tool built on top of Git. Repo helps manage many Git repositories, does the uploads to revision control systems, and automates parts of the development workflow."
+HOMEPAGE = "https://android.googlesource.com/tools/repo"
+SECTION = "console/utils"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "git://gerrit.googlesource.com/git-repo.git;protocol=https;branch=main \
+ file://0001-python3-shebang.patch \
+ "
+SRCREV = "0de4fc3001b36db7e107e61586296ca25bbf6d6d"
+
+MIRRORS += "git://gerrit.googlesource.com/git-repo.git git://github.com/GerritCodeReview/git-repo.git"
+
+S = "${WORKDIR}/git"
+
+do_configure:prepend() {
+ sed -Ei "s/REPO_REV\s*=\s*('|\")stable('|\")/REPO_REV = '${SRCREV}'/g" ${S}/repo
+}
+
+do_install() {
+ install -D ${WORKDIR}/git/repo ${D}${bindir}/repo
+}
+
+RDEPENDS:${PN} = "python3 git"
+
+BBCLASSEXTEND = "native nativesdk"