summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/quilt/quilt-0.63.inc
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-05-16 15:39:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-21 09:08:10 +0100
commit48c09163db18634e3071009b94645812ade285f4 (patch)
treee85f2cc9736094ec1d1200b772471727af022e67 /meta/recipes-devtools/quilt/quilt-0.63.inc
parent32c007bfc4fe7a0ba75644584bb80f8bdff09a01 (diff)
downloadopenembedded-core-contrib-48c09163db18634e3071009b94645812ade285f4.tar.gz
quilt: Update to 0.63 version
Upgrade quilt to 0.63 version and add perl-module-text-parsewords to RDEPENDS of ptest. Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/quilt/quilt-0.63.inc')
-rw-r--r--meta/recipes-devtools/quilt/quilt-0.63.inc59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-devtools/quilt/quilt-0.63.inc b/meta/recipes-devtools/quilt/quilt-0.63.inc
new file mode 100644
index 0000000000..f3757859ff
--- /dev/null
+++ b/meta/recipes-devtools/quilt/quilt-0.63.inc
@@ -0,0 +1,59 @@
+SUMMARY = "Tool for working with series of patches"
+HOMEPAGE = "http://savannah.nongnu.org/projects/quilt/"
+SECTION = "devel"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+SRC_URI = "${SAVANNAH_GNU_MIRROR}/quilt/quilt-${PV}.tar.gz \
+ file://install.patch \
+ file://run-ptest \
+ file://Makefile \
+"
+
+SRC_URI[md5sum] = "c0ef4beb58a6fa72563b955e70624b6e"
+SRC_URI[sha256sum] = "2846788221aa8844c54f10239c7cbc5e88031859162bcc285449446c3cfffe52"
+
+inherit autotools-brokensep ptest
+
+EXTRA_OECONF_darwin += "--without-date \
+ --without-getopt \
+ "
+
+PACKAGES += "guards guards-doc"
+FILES_${PN} = "${sysconfdir} ${datadir}/quilt \
+ ${bindir}/quilt ${libdir}/quilt"
+FILES_guards = "${bindir}/guards"
+FILES_${PN}-doc = "${mandir}/man1/quilt.1 ${docdir}/${BPN}"
+FILES_guards-doc = "${mandir}/man1/guards.1"
+
+RDEPENDS_${PN} = "bash"
+
+EXTRA_OE_MAKE_ARGS_darwin ?= ""
+EXTRA_OE_MAKE_ARGS ?= "BUILD_ROOT=${D}"
+
+CACHED_CONFIGUREVARS += "ac_cv_path_BASH=/bin/bash"
+
+# quilt ignores DESTDIR
+do_install () {
+ oe_runmake ${EXTRA_OE_MAKE_ARGS} install
+ # cleanup unpackaged files
+ rm -rf ${D}/${datadir}/emacs
+}
+
+do_compile_ptest() {
+ oe_runmake bin/patch-wrapper test/.depend
+}
+
+do_install_ptest() {
+ tar -cf - bin/ --exclude \*.in | ( cd ${D}${PTEST_PATH} && tar -xf - )
+ tar -cf - compat/ --exclude \*.in | ( cd ${D}${PTEST_PATH} && tar -xf - )
+ tar -cf - quilt/ --exclude \*.in | ( cd ${D}${PTEST_PATH} && tar -xf - )
+ tar -cf - test/ --exclude mail.test --exclude delete.test | ( cd ${D}${PTEST_PATH} && tar -xf - )
+ cp ${WORKDIR}/Makefile ${D}${PTEST_PATH}
+}
+
+RDEPENDS_${PN}-ptest = "make file sed gawk diffutils findutils ed perl \
+ perl-module-filehandle perl-module-getopt-std \
+ perl-module-posix perl-module-file-temp \
+ perl-module-text-parsewords \
+"