summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_3.1.1.1.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2019-10-29 10:47:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-30 13:47:05 +0000
commit14f04e6b6c1fa40a1c39cd186627b4b8442f2d5e (patch)
treed3cf04dbc4749ead7653dde36f3f9658aeba8e21 /meta/recipes-devtools/qemu/qemu_3.1.1.1.bb
parent5fc9b154754e67553296a00a39ed16ab6a1d59de (diff)
downloadopenembedded-core-contrib-14f04e6b6c1fa40a1c39cd186627b4b8442f2d5e.tar.gz
qemu: update to 3.1.1.1
bug fix only update. Drop patches included in update. For full set of changes, see: https://git.qemu.org/?p=qemu.git;a=shortlog;h=refs/tags/v3.1.1.1 Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_3.1.1.1.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_3.1.1.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_3.1.1.1.bb b/meta/recipes-devtools/qemu/qemu_3.1.1.1.bb
new file mode 100644
index 0000000000..04d8bee99f
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu_3.1.1.1.bb
@@ -0,0 +1,22 @@
+BBCLASSEXTEND = "nativesdk"
+
+require qemu.inc
+
+DEPENDS = "glib-2.0 zlib pixman"
+
+RDEPENDS_${PN}_class-target += "bash"
+
+EXTRA_OECONF_append_class-target = " --target-list=${@get_qemu_target_list(d)}"
+EXTRA_OECONF_append_class-nativesdk = " --target-list=${@get_qemu_target_list(d)}"
+
+do_install_append_class-nativesdk() {
+ ${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'make_qemu_wrapper', '', d)}
+}
+
+PACKAGECONFIG ??= " \
+ fdt sdl kvm \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'alsa xen', d)} \
+"
+PACKAGECONFIG_class-nativesdk ??= "fdt sdl kvm"
+
+