summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu.inc
diff options
context:
space:
mode:
authorJeremy Puhlman <jpuhlman@mvista.com>2020-03-11 15:25:42 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-12 22:49:23 +0000
commite8e5765cf2ad324a84634877eebc8289f1bc934f (patch)
tree219bb32b44d05ac25df06051e918fe36ad28bd28 /meta/recipes-devtools/qemu/qemu.inc
parent9e2db0ab1d4cacedde59e8915dff9a091e1c2d2b (diff)
downloadopenembedded-core-contrib-e8e5765cf2ad324a84634877eebc8289f1bc934f.tar.gz
qemu: Fix reproducibilty issues
tests/qemu-iotests/common.env is generated from configure which we pass ${HOSTTOOLS_DIR}/python3 as our python to use, which gets copied into the ptests. Correct python3 path. Signed-off-by: Jeremy A. Puhlman <jpuhlman@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu.inc')
-rw-r--r--meta/recipes-devtools/qemu/qemu.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index f3342eaf28..e6dbc6d05a 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -56,6 +56,8 @@ do_install_ptest() {
# Don't check the file genreated by configure
sed -i -e '/wildcard config-host.mak/d' \
-e '$ {/endif/d}' ${D}${PTEST_PATH}/tests/Makefile.include
+ sed -i -e 's,${HOSTTOOLS_DIR}/python3,${bindir}/python3,' \
+ ${D}/${PTEST_PATH}/tests/qemu-iotests/common.env
}
# QEMU_TARGETS is overridable variable