aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-12-22 18:59:47 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-02 17:24:15 +0000
commitdc2ddbf8cb825e577a2a35d96a1a2fa9042b74f8 (patch)
tree2873ae7f595a64c1405d5b6d4310f84e8b195d56 /meta/recipes-devtools/python
parent3d63452d8d8d8dc61cd26b7759b5c0d235d70451 (diff)
downloadopenembedded-core-contrib-dc2ddbf8cb825e577a2a35d96a1a2fa9042b74f8.tar.gz
python-gitdb: upgrade to v2.0.3
* Change PYPI_PACKAGE to gitdb2 to reflect upstream change * Now inherits setuptools rather than distutils Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-gitdb.inc8
-rw-r--r--meta/recipes-devtools/python/python3-gitdb_2.0.3.bb (renamed from meta/recipes-devtools/python/python3-gitdb_0.6.4.bb)2
2 files changed, 6 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python-gitdb.inc b/meta/recipes-devtools/python/python-gitdb.inc
index 5fa8885eb9..b32b869a02 100644
--- a/meta/recipes-devtools/python/python-gitdb.inc
+++ b/meta/recipes-devtools/python/python-gitdb.inc
@@ -6,10 +6,12 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=59e5ecb13339a936eedf83282eaf4528"
inherit pypi
-SRC_URI[md5sum] = "44e4366b8bdfd306b075c3a52c96ae1a"
-SRC_URI[sha256sum] = "a3ebbc27be035a2e874ed904df516e35f4a29a778a764385de09de9e0f139658"
+PYPI_PACKAGE = "gitdb2"
-DEPENDS = "${PYTHON_PN}-async ${PYTHON_PN}-smmap"
+SRC_URI[md5sum] = "d5217eb94ebd36fcec62b929d1f72b00"
+SRC_URI[sha256sum] = "b60e29d4533e5e25bb50b7678bbc187c8f6bcff1344b4f293b2ba55c85795f09"
+
+DEPENDS = "${PYTHON_PN}-async ${PYTHON_PN}-setuptools-native ${PYTHON_PN}-smmap"
RDEPENDS_${PN} += "${PYTHON_PN}-async \
${PYTHON_PN}-compression \
diff --git a/meta/recipes-devtools/python/python3-gitdb_0.6.4.bb b/meta/recipes-devtools/python/python3-gitdb_2.0.3.bb
index e46a438757..fe158327cb 100644
--- a/meta/recipes-devtools/python/python3-gitdb_0.6.4.bb
+++ b/meta/recipes-devtools/python/python3-gitdb_2.0.3.bb
@@ -1,2 +1,2 @@
-inherit distutils3
+inherit setuptools3
require python-gitdb.inc