aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-08-04 14:14:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-20 22:31:13 +0000
commit3328211afdef8ffb00dd4dff1143959d5412b075 (patch)
tree4903b2b0ed8c09605baf9c546eac47fa0617d83a /meta/recipes-devtools/python
parentc47b54aeae5daabb458d6f7118a16257021c1822 (diff)
downloadopenembedded-core-contrib-3328211afdef8ffb00dd4dff1143959d5412b075.tar.gz
python: fix RDEPENDS on several recipes, due to non-existent packages
The packaging has been altered slightly so ensure the dependencies are all still valid. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-async.inc2
-rw-r--r--meta/recipes-devtools/python/python-git.inc7
-rw-r--r--meta/recipes-devtools/python/python-gitdb.inc1
-rw-r--r--meta/recipes-devtools/python/python-scons_3.0.1.bb1
-rw-r--r--meta/recipes-devtools/python/python-setuptools.inc3
-rw-r--r--meta/recipes-devtools/python/python-smmap.inc1
-rw-r--r--meta/recipes-devtools/python/python3-pip_9.0.1.bb1
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.26.1.bb2
8 files changed, 3 insertions, 15 deletions
diff --git a/meta/recipes-devtools/python/python-async.inc b/meta/recipes-devtools/python/python-async.inc
index 0874667e0c..6664ab013c 100644
--- a/meta/recipes-devtools/python/python-async.inc
+++ b/meta/recipes-devtools/python/python-async.inc
@@ -9,6 +9,6 @@ inherit pypi
SRC_URI[md5sum] = "9b06b5997de2154f3bc0273f80bcef6b"
SRC_URI[sha256sum] = "ac6894d876e45878faae493b0cf61d0e28ec417334448ac0a6ea2229d8343051"
-RDEPENDS_${PN} += "${PYTHON_PN}-threading ${PYTHON_PN}-lang"
+RDEPENDS_${PN} += "${PYTHON_PN}-threading"
BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-devtools/python/python-git.inc b/meta/recipes-devtools/python/python-git.inc
index bef08eb74e..8d37693960 100644
--- a/meta/recipes-devtools/python/python-git.inc
+++ b/meta/recipes-devtools/python/python-git.inc
@@ -17,19 +17,14 @@ SRC_URI[sha256sum] = "ad61bc25deadb535b047684d06f3654c001d9415e1971e51c9c20f5b51
DEPENDS = "${PYTHON_PN}-gitdb"
-RDEPENDS_${PN} += "${PYTHON_PN}-argparse \
+RDEPENDS_${PN} += " \
${PYTHON_PN}-datetime \
- ${PYTHON_PN}-enum \
${PYTHON_PN}-gitdb \
${PYTHON_PN}-io \
- ${PYTHON_PN}-lang \
${PYTHON_PN}-logging \
${PYTHON_PN}-math \
${PYTHON_PN}-netclient \
- ${PYTHON_PN}-re \
- ${PYTHON_PN}-shell \
${PYTHON_PN}-stringold \
- ${PYTHON_PN}-subprocess \
${PYTHON_PN}-unittest \
${PYTHON_PN}-unixadmin \
git \
diff --git a/meta/recipes-devtools/python/python-gitdb.inc b/meta/recipes-devtools/python/python-gitdb.inc
index b32b869a02..2d5292e5d4 100644
--- a/meta/recipes-devtools/python/python-gitdb.inc
+++ b/meta/recipes-devtools/python/python-gitdb.inc
@@ -17,7 +17,6 @@ RDEPENDS_${PN} += "${PYTHON_PN}-async \
${PYTHON_PN}-compression \
${PYTHON_PN}-crypt \
${PYTHON_PN}-io \
- ${PYTHON_PN}-lang \
${PYTHON_PN}-mmap \
${PYTHON_PN}-shell \
${PYTHON_PN}-smmap \
diff --git a/meta/recipes-devtools/python/python-scons_3.0.1.bb b/meta/recipes-devtools/python/python-scons_3.0.1.bb
index 2f75b08d25..d5084b2d16 100644
--- a/meta/recipes-devtools/python/python-scons_3.0.1.bb
+++ b/meta/recipes-devtools/python/python-scons_3.0.1.bb
@@ -18,5 +18,4 @@ RDEPENDS_${PN} = "\
python-subprocess \
python-shell \
python-pprint \
- python-importlib \
"
diff --git a/meta/recipes-devtools/python/python-setuptools.inc b/meta/recipes-devtools/python/python-setuptools.inc
index d6eeeba2e3..54b7c300e0 100644
--- a/meta/recipes-devtools/python/python-setuptools.inc
+++ b/meta/recipes-devtools/python/python-setuptools.inc
@@ -30,15 +30,12 @@ RDEPENDS_${PN} = "\
${PYTHON_PN}-distutils \
${PYTHON_PN}-email \
${PYTHON_PN}-html \
- ${PYTHON_PN}-importlib \
${PYTHON_PN}-netserver \
${PYTHON_PN}-numbers \
${PYTHON_PN}-pkgutil \
${PYTHON_PN}-plistlib \
${PYTHON_PN}-shell \
- ${PYTHON_PN}-subprocess \
${PYTHON_PN}-stringold \
- ${PYTHON_PN}-textutils \
${PYTHON_PN}-threading \
${PYTHON_PN}-unittest \
${PYTHON_PN}-xml \
diff --git a/meta/recipes-devtools/python/python-smmap.inc b/meta/recipes-devtools/python/python-smmap.inc
index 32438350c1..55aa516e0a 100644
--- a/meta/recipes-devtools/python/python-smmap.inc
+++ b/meta/recipes-devtools/python/python-smmap.inc
@@ -13,7 +13,6 @@ SRC_URI[md5sum] = "d7932d5ace206bf4ae15198cf36fb6ab"
SRC_URI[sha256sum] = "0e2b62b497bd5f0afebc002eda4d90df9d209c30ef257e8673c90a6b5c119d62"
RDEPENDS_${PN} += "${PYTHON_PN}-codecs \
- ${PYTHON_PN}-lang \
${PYTHON_PN}-mmap \
"
BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-devtools/python/python3-pip_9.0.1.bb b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
index 4ce13da410..cd849eb08e 100644
--- a/meta/recipes-devtools/python/python3-pip_9.0.1.bb
+++ b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
@@ -37,7 +37,6 @@ do_install_append() {
RDEPENDS_${PN} = "\
python3-compile \
python3-io \
- python3-enum \
python3-html \
python3-json \
python3-netserver \
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.26.1.bb b/meta/recipes-devtools/python/python3-pygobject_3.26.1.bb
index 0405b44f17..91f2d53d78 100644
--- a/meta/recipes-devtools/python/python3-pygobject_3.26.1.bb
+++ b/meta/recipes-devtools/python/python3-pygobject_3.26.1.bb
@@ -24,7 +24,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wa
# we don't link against python3-pycairo -> RDEPENDS
PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo"
-RDEPENDS_${PN} += "python3-setuptools python3-importlib"
+RDEPENDS_${PN} += "python3-setuptools"
BBCLASSEXTEND = "native"
PACKAGECONFIG_class-native = ""