summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorJoshua Watt <jpewhacker@gmail.com>2020-02-11 21:14:33 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-14 13:04:49 +0000
commit64560fcbe7c9658fcca86010502d00998d88f418 (patch)
treeacfdb4711dbd41395432b1deb3663641c9a451a0 /meta/recipes-devtools/python
parent288becda36dcc9f5435ec00258c0d0594e0011c1 (diff)
downloadopenembedded-core-contrib-64560fcbe7c9658fcca86010502d00998d88f418.tar.gz
python: Add magic recipe
The python-magic module is used by diffoscope tool to make build comparisons. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-magic_0.4.15.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-magic_0.4.15.bb b/meta/recipes-devtools/python/python3-magic_0.4.15.bb
new file mode 100644
index 0000000000..698016ba4c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-magic_0.4.15.bb
@@ -0,0 +1,19 @@
+SUMMARY = "File type identification using libmagic"
+DESCRIPTION = "This module uses ctypes to access the libmagic file type \
+ identification library. It makes use of the local magic database and supports \
+ both textual and MIME-type output."
+HOMEPAGE = "http://github.com/ahupp/python-magic"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=16a934f165e8c3245f241e77d401bb88"
+
+PYPI_PACKAGE = "python-magic"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "e384c95a47218f66c6501cd6dd45ff59"
+SRC_URI[sha256sum] = "f3765c0f582d2dfc72c15f3b5a82aecfae9498bd29ca840d72f37d7bd38bfcd5"
+
+RDEPENDS_${PN} += "file"
+
+BBCLASSEXTEND = "native"