summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-17 17:12:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-18 23:27:20 +0000
commita0d056862c218f5fcd921905271169742cf464dc (patch)
treeade782e28d7388e85a2eea7f5a8a3b99655f2452 /meta/recipes-devtools/python
parent15b623e74846b7c7cd2f5e5b309e1379af86cf3f (diff)
downloadopenembedded-core-contrib-a0d056862c218f5fcd921905271169742cf464dc.tar.gz
python3-sphinx: Work around reproducibility issue
The dict used in this recipe doesn't write into the cache consistently, work around it until this issue is resolved in python upstream (similar to frozenset issues). Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-sphinx_4.4.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-sphinx_4.4.0.bb b/meta/recipes-devtools/python/python3-sphinx_4.4.0.bb
index 225e7737f6..97ec2619cb 100644
--- a/meta/recipes-devtools/python/python3-sphinx_4.4.0.bb
+++ b/meta/recipes-devtools/python/python3-sphinx_4.4.0.bb
@@ -10,6 +10,12 @@ SRC_URI[sha256sum] = "6caad9786055cb1fa22b4a365c1775816b876f91966481765d7d50e9f0
inherit setuptools3 pypi
+
+do_install:append () {
+ # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
+ rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
+}
+
RDEPENDS:${PN} = "\
python3-packaging python3-docutils python3-requests \
python3-imagesize python3-alabaster python3-jinja2 \