aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-10-08 14:28:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-09 12:02:41 +0100
commitdd644ee9991e953474d41dbbf713a7e33b4c9141 (patch)
tree04051733d1be8f84546ea64fb4786cadab43617f /meta/recipes-devtools/python
parenta8098782fab87498026a09c06716b631c77c5ad6 (diff)
downloadopenembedded-core-contrib-dd644ee9991e953474d41dbbf713a7e33b4c9141.tar.gz
python3: add ca-certificates to python3-crypt RRECOMMENDS
It's likely that the certificate root chain is needed if python3-crypt is installed, so recommend it. Also remove the redundant nativesdk-python3-crypt assignment, as the general form is sufficient when class-extended. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3_3.5.6.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.6.bb b/meta/recipes-devtools/python/python3_3.5.6.bb
index 6085e36b7d..e179658134 100644
--- a/meta/recipes-devtools/python/python3_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3_3.5.6.bb
@@ -217,8 +217,7 @@ py_package_preprocess () {
# manual dependency additions
RPROVIDES_${PN}-modules = "${PN}"
RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules"
-RRECOMMENDS_${PN}-crypt = "openssl"
-RRECOMMENDS_${PN}-crypt_class-nativesdk = "nativesdk-openssl"
+RRECOMMENDS_${PN}-crypt = "openssl ca-certificates"
FILES_${PN}-2to3 += "${bindir}/2to3-${PYTHON_MAJMIN}"
FILES_${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"