aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@gmail.com>2018-09-19 09:22:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-21 08:15:19 -0700
commit5a5a97b1c3914ad4a3e94981bf53897d0a3f4fb3 (patch)
treec9bba9042274cd2c00ec996b62f8a45ae9cebcec /meta/recipes-devtools/python
parent3c62c42ebde9dd4acdc74c56160d6ce8639b497c (diff)
downloadopenembedded-core-contrib-5a5a97b1c3914ad4a3e94981bf53897d0a3f4fb3.tar.gz
python: respect package order in manifest
Don't sort the manifest when using it to generate packaging rules, so ordering can be used to have complex packaging rules. This is a backport of the same changes done by Ross Burton for python3 Changes since v1: - Rebase Signed-off-by: Andrew Geissler <geissonator@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python_2.7.15.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.15.bb b/meta/recipes-devtools/python/python_2.7.15.bb
index 43d9ff5152..472c1da4bf 100644
--- a/meta/recipes-devtools/python/python_2.7.15.bb
+++ b/meta/recipes-devtools/python/python_2.7.15.bb
@@ -207,7 +207,7 @@ RPROVIDES_${PN} += "${PN}-modules"
INCLUDE_PYCS ?= "1"
python(){
- import json
+ import collections, json
filename = os.path.join(d.getVar('THISDIR'), 'python', 'python2-manifest.json')
# This python changes the datastore based on the contents of a file, so mark
@@ -215,7 +215,7 @@ python(){
bb.parse.mark_dependency(d, filename)
with open(filename) as manifest_file:
- python_manifest=json.load(manifest_file)
+ python_manifest=json.load(manifest_file, object_pairs_hook=collections.OrderedDict)
include_pycs = d.getVar('INCLUDE_PYCS')
@@ -248,8 +248,6 @@ python(){
d.appendVar('RDEPENDS_' + pypackage, ' ' + pn + '-' + value)
d.setVar('SUMMARY_' + pypackage, python_manifest[key]['summary'])
- # We need to ensure staticdev packages match for files first so we sort in reverse
- newpackages.sort(reverse=True)
# Prepending so to avoid python-misc getting everything
packages = newpackages + packages
d.setVar('PACKAGES', ' '.join(packages))