summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-04-30 13:54:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-30 15:47:21 +0100
commit0e2858bd7d6f013bb31b64552a9ea5873c4f7ced (patch)
tree004efa3367a6dba69ef2e10ebb2dd2ec9d383d5f /meta/recipes-devtools/python
parent07db18609ce2b868d4ff5eb6cf2128bf6eb6d682 (diff)
downloadopenembedded-core-contrib-0e2858bd7d6f013bb31b64552a9ea5873c4f7ced.tar.gz
python3-pycairo: update to 1.18.1
Switch over to meson build, as it does not attempt to install headers into /usr/share and pkg-config files into /usr/share/$libdir. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-pycairo_1.18.1.bb (renamed from meta/recipes-devtools/python/python3-pycairo_1.15.6.bb)14
1 files changed, 5 insertions, 9 deletions
diff --git a/meta/recipes-devtools/python/python3-pycairo_1.15.6.bb b/meta/recipes-devtools/python/python3-pycairo_1.18.1.bb
index 5c3e1e6f03..5aaa01a00a 100644
--- a/meta/recipes-devtools/python/python3-pycairo_1.15.6.bb
+++ b/meta/recipes-devtools/python/python3-pycairo_1.18.1.bb
@@ -8,24 +8,20 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=f2e071ab72978431b294a0d696327421 \
file://COPYING-MPL-1.1;md5=bfe1f75d606912a4111c90743d6c7325"
# cairo >= 1.14
-DEPENDS = "cairo"
+DEPENDS = "cairo python3"
SRC_URI = "https://github.com/pygobject/pycairo/releases/download/v${PV}/pycairo-${PV}.tar.gz"
UPSTREAM_CHECK_URI = "https://github.com/pygobject/pycairo/releases/"
-SRC_URI[md5sum] = "3ff210c34e7b052590e15fd0fb147766"
-SRC_URI[sha256sum] = "ad150ea637860836b66705e0513b8e59494538f0b80497ad3462051368755016"
+SRC_URI[md5sum] = "7610da8a40a7bed548991aa3416431d1"
+SRC_URI[sha256sum] = "70172e58b6bad7572a3518c26729b074acdde15e6fee6cbab6d3528ad552b786"
S = "${WORKDIR}/pycairo-${PV}"
-inherit setuptools3 pkgconfig
+inherit meson pkgconfig
CFLAGS += "-fPIC"
BBCLASSEXTEND = "native"
-do_install_append() {
- install -d ${D}${includedir}/pycairo/
- install -m 0644 ${D}${datadir}/include/pycairo/py3cairo.h ${D}${includedir}/pycairo/
-}
-FILES_${PN} += "${datadir}/include/pycairo/py3cairo.h"
+FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"