summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-04-30 11:58:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-03 15:38:03 +0100
commit6dbe449ac2ed7c93f71f00d53237c6aba4ebbf81 (patch)
tree46b81a1bdc6f24db74a2855e1c3ca9245f48e571 /meta/recipes-devtools/python
parent075ce9fdbac8c58696cf5a9718446f94352b6ce8 (diff)
downloadopenembedded-core-contrib-6dbe449ac2ed7c93f71f00d53237c6aba4ebbf81.tar.gz
python3-dbusmock: add recipe from meta-oe
This is needed for glib ptests. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-dbusmock_0.19.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dbusmock_0.19.bb b/meta/recipes-devtools/python/python3-dbusmock_0.19.bb
new file mode 100644
index 0000000000..5389e48973
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dbusmock_0.19.bb
@@ -0,0 +1,16 @@
+SUMMARY = "With this program/Python library you can easily create mock objects on D-Bus"
+
+LICENSE = "GPL-3.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
+
+SRC_URI[sha256sum] = "497f30eed2fcd5deaa2633b9622e4e99af4bdfba4e972b350ba630bac6fc86c2"
+
+PYPI_PACKAGE = "python-dbusmock"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-dbus \
+ ${PYTHON_PN}-pygobject \
+ ${PYTHON_PN}-xml \
+ "