summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-04-25 19:28:09 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-29 15:00:36 +0100
commit85c025a7072558e49e4cf77ce03b3d156b9377a0 (patch)
tree077d5da8129febc64b49c3584bb5dfffd96717e7 /meta/recipes-devtools/python
parent4f024e10f2c889ca8c09257b7c09f2cbe2eb6d4e (diff)
downloadopenembedded-core-contrib-85c025a7072558e49e4cf77ce03b3d156b9377a0.tar.gz
python3-pyparsing: add from meta-oe
This is needed for python3-cython, which is needed by new python3-numpy. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-pyparsing.inc22
-rw-r--r--meta/recipes-devtools/python/python3-pyparsing_2.4.6.bb2
2 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pyparsing.inc b/meta/recipes-devtools/python/python-pyparsing.inc
new file mode 100644
index 0000000000..a768c97fce
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pyparsing.inc
@@ -0,0 +1,22 @@
+SUMMARY = "Python parsing module"
+HOMEPAGE = "http://pyparsing.wikispaces.com/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=657a566233888513e1f07ba13e2f47f1"
+
+SRC_URI[md5sum] = "29733ea8cbee0291aad121c69c6e51a1"
+SRC_URI[sha256sum] = "4c830582a84fb022400b85429791bc551f1f4871c33f23e44f353119e92f969f"
+UPSTREAM_CHECK_REGEX = "pyparsing-(?P<pver>.*)\.tar"
+
+inherit pypi
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/python/python3-pyparsing_2.4.6.bb b/meta/recipes-devtools/python/python3-pyparsing_2.4.6.bb
new file mode 100644
index 0000000000..0805fee3e2
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pyparsing_2.4.6.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pyparsing.inc