summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorJoshua Watt <jpewhacker@gmail.com>2020-02-11 21:14:32 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-14 13:04:49 +0000
commit288becda36dcc9f5435ec00258c0d0594e0011c1 (patch)
tree55d83395ed513373dbeae10ed89630473cea7df7 /meta/recipes-devtools/python
parentc127e7ac7c6da11417a599384002fd7c1420c7c2 (diff)
downloadopenembedded-core-contrib-288becda36dcc9f5435ec00258c0d0594e0011c1.tar.gz
python: Add libarchive-c recipe
The libarchive python module is used by diffoscope tool to make build comparisons. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-libarchive-c_2.9.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-libarchive-c_2.9.bb b/meta/recipes-devtools/python/python3-libarchive-c_2.9.bb
new file mode 100644
index 0000000000..4983ae527a
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-libarchive-c_2.9.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Python interface to libarchive"
+DESCRIPTION = "A Python interface to libarchive. It uses the standard ctypes module to \
+ dynamically load and access the C library."
+HOMEPAGE = "https://github.com/Changaco/python-libarchive-c"
+LICENSE = "CC0-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=bcab380227a83bc147350b40a81e6ffc"
+
+PYPI_PACKAGE = "libarchive-c"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "083bd2cb0043c1e22a52cb9a05e31532"
+SRC_URI[sha256sum] = "9919344cec203f5db6596a29b5bc26b07ba9662925a05e24980b84709232ef60"
+
+RDEPENDS_${PN} += "libarchive"
+
+BBCLASSEXTEND = "native"