aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2017-03-15 13:17:26 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-16 17:36:10 +0000
commitcb2073658305b605cccc60439b62c1dc515d9a8d (patch)
treee81c34ed6b9c4147079821e42b29cdb9272c406e /meta/recipes-devtools/python
parent006ab8c6bcfe9d065c215cab15289357cefc9259 (diff)
downloadopenembedded-core-contrib-cb2073658305b605cccc60439b62c1dc515d9a8d.tar.gz
python3-pip: support native builds
Add native pip3 support. [YOCTO#11049] [YOCTO#11022] Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-pip_9.0.1.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_9.0.1.bb b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
index b6dbb6e5f2..4456b9b1b1 100644
--- a/meta/recipes-devtools/python/python3-pip_9.0.1.bb
+++ b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
@@ -34,6 +34,11 @@ do_install_append() {
# Installed eggs need to be passed directly to the interpreter via a pth file
echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth
+
+ # Make sure we use /usr/bin/env python3
+ for PYTHSCRIPT in `grep -rIl ${bindir} ${D}${bindir}/pip3*`; do
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
+ done
}
RDEPENDS_${PN} = "\
@@ -47,3 +52,5 @@ RDEPENDS_${PN} = "\
python3-unixadmin \
python3-xmlrpc \
"
+
+BBCLASSEXTEND = "native"