aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-03 12:06:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-09 10:50:54 +0000
commit5c8dda390cacef69bc7996eb26099d55e2b8427b (patch)
treea0f36c971c1abcad025a230ee93575d9a507235d /meta/recipes-devtools/python
parent2a60bba00da9c4e2b1a1ce30e509dba82cc6c94a (diff)
downloadopenembedded-core-contrib-5c8dda390cacef69bc7996eb26099d55e2b8427b.tar.gz
python3-native: Remove tests to save copying uneeded files around
Removing these nearly halves the python3-native disk footprint meaning more optimal sysroot operations. We don't need these tests for anything. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.2.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.2.bb b/meta/recipes-devtools/python/python3-native_3.5.2.bb
index 7ac3942831..bf4e6860fa 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.2.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.2.bb
@@ -98,4 +98,7 @@ do_install() {
for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
done
+
+ # Tests are large and we don't need them in the native sysroot
+ rm ${D}${libdir}/python${PYTHON_MAJMIN}/test -rf
}