aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-02-27 14:02:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 11:17:22 +0000
commit0a1427bf9aeeda6bee2cc0af8da4ea5fd90aef6f (patch)
tree832a708208f36aa18b43b090f8963683f03986ee /meta/recipes-devtools/python
parent6db26339522a22c3e3c13287ea0c9daf40c7c15e (diff)
downloadopenembedded-core-contrib-0a1427bf9aeeda6bee2cc0af8da4ea5fd90aef6f.tar.gz
recipes: Make use of the new bb.utils.filter() function
Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-smartpm_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm_git.bb b/meta/recipes-devtools/python/python-smartpm_git.bb
index 6daabf49a6..31c273deaf 100644
--- a/meta/recipes-devtools/python/python-smartpm_git.bb
+++ b/meta/recipes-devtools/python/python-smartpm_git.bb
@@ -81,12 +81,12 @@ do_install_append() {
# Disable zypper channel support
rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/zyppchannelsync.py*
- if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'rpm', 'rpm', '', d)}" ]; then
+ if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'rpm', d)}" ]; then
rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/rpmdir.py*
rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/backends/rpm
fi
- if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'qt4', 'qt4', '', d)}" ]; then
+ if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'qt4', d)}" ]; then
rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/interfaces/qt4
fi