summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-10-02 12:04:05 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-10-04 23:54:51 +0100
commit5c287a896fa9f5cd05b6a2411528fdc8fb2579d6 (patch)
tree05ec5696babd085119dba03b432d64ed2180ce64 /meta/recipes-devtools/python
parentba738a1e2944468ef3e4d9c9810e98457fcd3b85 (diff)
downloadopenembedded-core-contrib-5c287a896fa9f5cd05b6a2411528fdc8fb2579d6.tar.gz
python3-numpy: remove obsolete reproducible workaround
We currently delete some pycache files because frozenset wasn't able to be reproducible, but this has been fixed in Python 3.11: https://github.com/python/cpython/commit/33d95c6facdfda3c8c0feffa7a99184e4abc2f63 Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-numpy_1.26.0.bb9
1 files changed, 0 insertions, 9 deletions
diff --git a/meta/recipes-devtools/python/python3-numpy_1.26.0.bb b/meta/recipes-devtools/python/python3-numpy_1.26.0.bb
index 4e1e34e8df..3ae40a33fb 100644
--- a/meta/recipes-devtools/python/python3-numpy_1.26.0.bb
+++ b/meta/recipes-devtools/python/python3-numpy_1.26.0.bb
@@ -30,15 +30,6 @@ do_compile:prepend() {
export NPY_DISABLE_SVML=1
}
-# Unfortunately the following pyc files are non-deterministc due to 'frozenset'
-# being written without strict ordering, even with PYTHONHASHSEED = 0
-# Upstream is discussing ways to solve the issue properly, until then let's
-# just not install the problematic files.
-# More info: http://benno.id.au/blog/2013/01/15/python-determinism
-do_install:append() {
- rm ${D}${PYTHON_SITEPACKAGES_DIR}/numpy/typing/tests/data/pass/__pycache__/literal.cpython*
-}
-
FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
# install what is needed for numpy.test()