summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-11-22 22:40:04 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-26 16:58:29 +0000
commitd56fcb5806784359a9e81ea5ac4816caaeee7750 (patch)
treef39df3a2be24d5b911852652e3da38bc7e4a07e7 /meta/recipes-devtools/python
parent9172d61c57e23682c3d2c25701cbd53c84d01a27 (diff)
downloadopenembedded-core-contrib-d56fcb5806784359a9e81ea5ac4816caaeee7750.tar.gz
python: introduce python3-dtschema
kernel commit 53182e81f47d [kbuild: Enable DT schema checks for %.dtb targets], which is part of v5.16+, makes the checking of dtb schemas manditory. To support the checking, we introduce this new recipe dtschema. Dependencies will be imported in subsequent commits, so we can track the dependency need on a per-import basis. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-dtschema_2021.10.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dtschema_2021.10.bb b/meta/recipes-devtools/python/python3-dtschema_2021.10.bb
new file mode 100644
index 0000000000..627aed496f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dtschema_2021.10.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Tooling for devicetree validation using YAML and jsonschema"
+HOMEPAGE = "https://github.com/devicetree-org/dt-schema"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=457495c8fa03540db4a576bf7869e811"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "dtschema"
+
+SRC_URI[md5sum] = "d2f0d847ba2ad4d223317ef7304342b0"
+SRC_URI[sha256sum] = "d09c94d13f46e6674ba11ff31220651ad1b02dae860f5a87905dfac6b8d768d9"
+
+DEPENDS += "python3-setuptools-scm-native"
+RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987"
+
+BBCLASSEXTEND = "native nativesdk"