summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-11 12:03:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-13 12:21:07 +0000
commit3bdf64b97facce9706cc579bdbc9a80e0d48428f (patch)
tree87250844be228d473eb8484324c5cbb70735c38a /meta/recipes-devtools/python
parent15baf24f750ab2c8b0a46d4a3bf2ae9bfa3d0aff (diff)
downloadopenembedded-core-contrib-3bdf64b97facce9706cc579bdbc9a80e0d48428f.tar.gz
meta: rename pip_install_wheel.bbclass to python_pep517.bbclass
pip_install_wheel shouldn't restricted to just using Pip to install wheels (the installer module is simplier and likely a better option), and in the future may be extended to also provide do_compile() using the build module. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-flit-core_3.7.1.bb2
-rw-r--r--meta/recipes-devtools/python/python3-pip_22.0.3.bb2
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_59.5.0.bb2
-rw-r--r--meta/recipes-devtools/python/python3-wheel_0.37.1.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb b/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
index 1f14345d50..b12b8e42d7 100644
--- a/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
+++ b/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
@@ -21,7 +21,7 @@ PYPI_PACKAGE = "flit"
PEP517_SOURCE_PATH = "${S}/flit_core"
do_install:class-native () {
- pip_install_wheel_do_bootstrap_install
+ python_pep517_do_bootstrap_install
}
PACKAGES =+ "${PN}-tests"
diff --git a/meta/recipes-devtools/python/python3-pip_22.0.3.bb b/meta/recipes-devtools/python/python3-pip_22.0.3.bb
index bce3b68861..bfeeee789c 100644
--- a/meta/recipes-devtools/python/python3-pip_22.0.3.bb
+++ b/meta/recipes-devtools/python/python3-pip_22.0.3.bb
@@ -19,7 +19,7 @@ SRC_URI += "file://reproducible.patch"
SRC_URI[sha256sum] = "f29d589df8c8ab99c060e68ad294c4a9ed896624f6368c5349d70aa581b333d0"
do_install:class-native() {
- pip_install_wheel_do_bootstrap_install
+ python_pep517_do_bootstrap_install
# pip install would normally generate [console_scripts] in ${bindir}
install -d ${D}/${bindir}
diff --git a/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb b/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
index 7cd67b85f9..d93972b9a0 100644
--- a/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
@@ -22,7 +22,7 @@ DEPENDS:remove:class-native = "python3-pip-native python3-setuptools-native"
DEPENDS:append:class-native = " unzip-native"
do_install:class-native() {
- pip_install_wheel_do_bootstrap_install
+ python_pep517_do_bootstrap_install
}
RDEPENDS:${PN} = "\
diff --git a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
index cf0d8191b4..a339e65824 100644
--- a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
+++ b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
@@ -13,7 +13,7 @@ SRC_URI += " file://0001-Backport-pyproject.toml-from-flit-backend-branch.patch"
DEPENDS:remove:class-native = "python3-pip-native"
do_install:class-native () {
- pip_install_wheel_do_bootstrap_install
+ python_pep517_do_bootstrap_install
# pip install would normally generate [project.scripts] in ${bindir}
install -d ${D}/${bindir}