aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-08-12 21:03:35 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-17 10:35:42 +0100
commitb2e6ac630af3ad8dd7ba142c365cb6b7ebfa278c (patch)
tree714b959231c48dd9b2ecf8f4ae71b9bc0d0269af /meta/recipes-devtools/python
parent97ddbc8a52c428a01a3133f8a0e813b62a0e59fc (diff)
downloadopenembedded-core-contrib-b2e6ac630af3ad8dd7ba142c365cb6b7ebfa278c.tar.gz
python3-git: Fixes dependencies, avoiding to install python3-misc
This patch adds the following dependencies to be able to import git on python3: python3-enum, python3-logging, python3-datetime, python3-netclient. [YOCTO #9757] (From OE-Core rev: 9d232fadfaad4170bc867e0b97bbd0ec7cc9ade4) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-git_2.0.7.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-git_2.0.7.bb b/meta/recipes-devtools/python/python3-git_2.0.7.bb
index 6620444a86..c9fe9baa20 100644
--- a/meta/recipes-devtools/python/python3-git_2.0.7.bb
+++ b/meta/recipes-devtools/python/python3-git_2.0.7.bb
@@ -4,4 +4,4 @@ DEPENDS = "python3-gitdb"
inherit setuptools3
-RDEPENDS_${PN} += "python3-gitdb python3-lang python3-io python3-shell python3-math python3-re python3-subprocess python3-stringold python3-unixadmin"
+RDEPENDS_${PN} += "python3-gitdb python3-lang python3-io python3-shell python3-math python3-re python3-subprocess python3-stringold python3-unixadmin python3-enum python3-logging python3-datetime python3-netclient"