aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.5.5.bb
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandro.enedino.hernandez-samaniego@xilinx.com>2018-09-04 23:45:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-06 10:36:05 +0100
commitb94af33b5ffdd62617cf69fca4d99e927447740a (patch)
tree363e8e13ba456470c1ac6a2f145e21e380791f1b /meta/recipes-devtools/python/python3_3.5.5.bb
parenta6fab3ca81e3dc6ee226840ed7e9f1cd21ecbc2a (diff)
downloadopenembedded-core-contrib-b94af33b5ffdd62617cf69fca4d99e927447740a.tar.gz
python3: Modify create_manifest to make it versionless
This patch improves the create_manifest script by making it use PYTHON_MAJMIN instead of hard coded paths containing the version number when looking at the necessary modules for every package, the script should now be independent of the python(3) version on which were working Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandr@xilinx.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.5.5.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.5.5.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.5.bb b/meta/recipes-devtools/python/python3_3.5.5.bb
index 8afe15eee6..9e31fa6f29 100644
--- a/meta/recipes-devtools/python/python3_3.5.5.bb
+++ b/meta/recipes-devtools/python/python3_3.5.5.bb
@@ -334,7 +334,7 @@ do_create_manifest() {
cd ${WORKDIR}
# This needs to be executed by python-native and NOT by HOST's python
- nativepython3 create_manifest3.py
+ nativepython3 create_manifest3.py ${PYTHON_MAJMIN}
cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json
}