aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.5.1.bb
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-23 18:23:59 -0300
committerFabio Berton <fabio.berton@ossystems.com.br>2016-08-31 10:21:27 -0300
commit6acbda5ac9c4edbcabbe11227db1655fbc8d904c (patch)
tree461d7e27852e0cfed200d82572c7f53ab6a11f13 /meta/recipes-devtools/python/python3_3.5.1.bb
parent9681e957fbf3370a6905b54e42dac17fa976db70 (diff)
downloadopenembedded-core-contrib-6acbda5ac9c4edbcabbe11227db1655fbc8d904c.tar.gz
python-3.5-manifest: Add argparse module
Adding argparse module from Python's standard library. This allow use argparse without installing all python-misc modules. For compatibility, add python3-argparse as RDEPENDS to python3-misc. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> (cherry picked from commit f2b96001e074d26f5eb8711c2217a695fb02de4c)
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.5.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.1.bb b/meta/recipes-devtools/python/python3_3.5.1.bb
index 2fbb3cbc30..37ef26775b 100644
--- a/meta/recipes-devtools/python/python3_3.5.1.bb
+++ b/meta/recipes-devtools/python/python3_3.5.1.bb
@@ -215,7 +215,7 @@ INSANE_SKIP_${PN}-dev += "dev-elf"
# catch all the rest (unsorted)
PACKAGES += "${PN}-misc"
-RDEPENDS_${PN}-misc += "${PN}-core"
+RDEPENDS_${PN}-misc += "${PN}-core ${PN}-argparse"
RDEPENDS_${PN}-modules += "${PN}-misc"
FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"