aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.5.1.bb
diff options
context:
space:
mode:
authorAwais Belal <awais_belal@mentor.com>2016-06-14 16:26:08 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 18:05:22 +0100
commitfe4184da57dd47b01508bd2ee44c307944a83c0b (patch)
treec715474a1b0752b1846287cf87fbb3ee98de11fe /meta/recipes-devtools/python/python3_3.5.1.bb
parentce6e49a01f1c1dc7e961534d0c43b4e2372ed9b0 (diff)
downloadopenembedded-core-contrib-fe4184da57dd47b01508bd2ee44c307944a83c0b.tar.gz
python3: fix CROSSPYTHONPATH for cross builds
There are cases where target and host are of the same type and at such instances the target modules may be loaded if CROSSPYTHONPATH is not correct. This adds host library paths so that target modules are not loaded while cross compiling to avoid illegal instruction issues. (From OE-Core rev: 20c637ef40f2de9c2848ac1fb25240dea84cdb7b) Signed-off-by: Awais Belal <awais_belal@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.5.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.1.bb b/meta/recipes-devtools/python/python3_3.5.1.bb
index ebfdcdb749..78ae1740e3 100644
--- a/meta/recipes-devtools/python/python3_3.5.1.bb
+++ b/meta/recipes-devtools/python/python3_3.5.1.bb
@@ -70,8 +70,8 @@ export _PYTHON_PROJECT_BASE = "${B}"
export _PYTHON_PROJECT_SRC = "${S}"
export CCSHARED = "-fPIC"
-# Fix ctypes cross compilation
-export CROSSPYTHONPATH = "${B}/build/lib.linux-${TARGET_ARCH}-${PYTHON_MAJMIN}:${S}/Lib:${S}/Lib/plat-linux"
+# Fix cross compilation of different modules
+export CROSSPYTHONPATH = "${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/:${B}/build/lib.linux-${TARGET_ARCH}-${PYTHON_MAJMIN}:${S}/Lib:${S}/Lib/plat-linux"
# No ctypes option for python 3
PYTHONLSBOPTS = ""