aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-02-27 12:49:22 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-05 22:14:19 +0100
commit45290ff4d1902bd0ab5377568f969fbb660c0c87 (patch)
tree1bab381b67f24b173b38a54cb599689fc9fe0f7a /meta/recipes-devtools/python/python3
parent4563788a21fb1715920cd5056b43d85c69563c32 (diff)
downloadopenembedded-core-contrib-45290ff4d1902bd0ab5377568f969fbb660c0c87.tar.gz
python3: Upgrade from 3.3.3 to 3.4.2
Modifies: python3-native_3.3.3.bb -> python3-native_3.4.2.bb: Updates checksums, version, patches and SRC_URIs to use xz format, LICENSE did not change, dates were updated, adds fix for ctypes/libffi needed for pip <- required since Python 3.4 (see PEP #453). python3_3.3.3.bb -> python3_3.4.2.bb: Updates checksums, version, patches and SRC_URIs to use xz format, adds fix for ctypes/libffi, fixes oe_multilib_header() call, adds python3-core as RDEPENDS to python3-misc to avoid QA issue. generate-manifest-3.4.py - > generate-manifest-3.4.py: fixes reprlib, adds _sitebuiltins and _collections_abc <- formerly part of collections, separated since 3.4 python-3.3-manifest.inc -> python-3.4-manifest.inc Rebases: 12-distutils-prefix-is-inside-staging-area.patch python-3.3-multilib.patch 04-default-is-optimized.patch avoid-ncursesw-include-path.patch Deletes (fixed upstream): fix-ast.h-dependency.patch python3-fix-build-error-with-Readline-6.3.patch 06-ctypes-libffi-fix-configure.patch remove_sqlite_rpath.patch [YOCTO #6857] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3')
-rw-r--r--meta/recipes-devtools/python/python3/04-default-is-optimized.patch39
-rw-r--r--meta/recipes-devtools/python/python3/12-distutils-prefix-is-inside-staging-area.patch29
-rw-r--r--meta/recipes-devtools/python/python3/avoid-ncursesw-include-path.patch30
-rw-r--r--meta/recipes-devtools/python/python3/python-3.3-multilib.patch180
4 files changed, 138 insertions, 140 deletions
diff --git a/meta/recipes-devtools/python/python3/04-default-is-optimized.patch b/meta/recipes-devtools/python/python3/04-default-is-optimized.patch
index d5afd40025..3b8f264a58 100644
--- a/meta/recipes-devtools/python/python3/04-default-is-optimized.patch
+++ b/meta/recipes-devtools/python/python3/04-default-is-optimized.patch
@@ -1,20 +1,21 @@
Upstream-Status: Inappropriate [embedded specific]
-Updated original patch for python 2.7.3
-
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
-2012/05/01
-
-
# when compiling for an embedded system, we need every bit of
# performance we can get. default to optimized with the option
# of opt-out.
# Signed-Off: Michael 'Mickey' Lauer <mickey@vanille-media.de>
-Index: Python-3.2.3/Python/compile.c
+
+2012/05/01
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+
+Rebased for 3.4.2 02/2015
+Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
+
+Index: Python-3.4.2/Python/compile.c
===================================================================
---- Python-3.2.3.orig/Python/compile.c 2012-04-10 23:54:08.000000000 -0700
-+++ Python-3.2.3/Python/compile.c 2012-09-19 15:58:46.649123998 -0700
+--- Python-3.4.2.orig/Python/compile.c
++++ Python-3.4.2/Python/compile.c
@@ -30,7 +30,7 @@
#include "symtable.h"
#include "opcode.h"
@@ -24,28 +25,28 @@ Index: Python-3.2.3/Python/compile.c
#define DEFAULT_BLOCK_SIZE 16
#define DEFAULT_BLOCKS 8
-Index: Python-3.2.3/Modules/main.c
+Index: Python-3.4.2/Modules/main.c
===================================================================
---- Python-3.2.3.orig/Modules/main.c 2012-04-10 23:54:07.000000000 -0700
-+++ Python-3.2.3/Modules/main.c 2012-09-19 16:00:32.153124053 -0700
-@@ -46,7 +46,7 @@
+--- Python-3.4.2.orig/Modules/main.c
++++ Python-3.4.2/Modules/main.c
+@@ -38,7 +38,7 @@ static wchar_t **orig_argv;
static int orig_argc;
/* command line options */
--#define BASE_OPTS L"bBc:dEhiJm:OqRsStuvVW:xX:?"
-+#define BASE_OPTS L"bBc:dEhiJm:NOqRsStuvVW:xX:?"
+-#define BASE_OPTS L"bBc:dEhiIJm:OqRsStuvVW:xX:?"
++#define BASE_OPTS L"bBc:dEhiIJm:NOqRsStuvVW:xX:?"
#define PROGRAM_OPTS BASE_OPTS
-@@ -71,6 +71,7 @@
+@@ -64,6 +64,7 @@ static char *usage_2 = "\
-m mod : run library module as a script (terminates option list)\n\
-O : optimize generated bytecode slightly; also PYTHONOPTIMIZE=x\n\
-OO : remove doc-strings in addition to the -O optimizations\n\
+-N : do NOT optimize generated bytecode\n\
-q : don't print version and copyright messages on interactive startup\n\
- -R : use a pseudo-random salt to make hash() values of various types be\n\
- unpredictable between separate invocations of the interpreter, as\n\
-@@ -407,8 +408,8 @@
+ -s : don't add user site directory to sys.path; also PYTHONNOUSERSITE\n\
+ -S : don't imply 'import site' on initialization\n\
+@@ -418,8 +419,8 @@ Py_Main(int argc, wchar_t **argv)
/* case 'J': reserved for Jython */
diff --git a/meta/recipes-devtools/python/python3/12-distutils-prefix-is-inside-staging-area.patch b/meta/recipes-devtools/python/python3/12-distutils-prefix-is-inside-staging-area.patch
index c5846a5af8..bf02df2025 100644
--- a/meta/recipes-devtools/python/python3/12-distutils-prefix-is-inside-staging-area.patch
+++ b/meta/recipes-devtools/python/python3/12-distutils-prefix-is-inside-staging-area.patch
@@ -1,15 +1,18 @@
Upstream-Status: Inappropriate [embedded specific]
+02/2015 Rebased for Python 3.4.2
+
# The proper prefix is inside our staging area.
# Signed-Off: Michael 'Mickey' Lauer <mickey@vanille-media.de>
# Signed-off-by: Phil Blundell <philb@gnu.org>
# Signed-off-by: Khem Raj <raj.khem@gmail.com>
+# Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
-Index: Python-3.3.2/Lib/distutils/sysconfig.py
+Index: Python-3.4.2/Lib/distutils/sysconfig.py
===================================================================
---- Python-3.3.2.orig/Lib/distutils/sysconfig.py 2013-07-30 00:00:52.769749805 -0700
-+++ Python-3.3.2/Lib/distutils/sysconfig.py 2013-07-30 00:16:22.545767248 -0700
-@@ -16,10 +16,11 @@
+--- Python-3.4.2.orig/Lib/distutils/sysconfig.py
++++ Python-3.4.2/Lib/distutils/sysconfig.py
+@@ -16,10 +16,11 @@ import sys
from .errors import DistutilsPlatformError
# These are needed in a couple of spots, so just compute them once.
@@ -25,7 +28,7 @@ Index: Python-3.3.2/Lib/distutils/sysconfig.py
# Path to the base directory of the project. On Windows the binary may
# live in project/PCBuild9. If we're dealing with an x64 Windows build,
-@@ -93,7 +94,9 @@
+@@ -93,7 +94,9 @@ def get_python_inc(plat_specific=0, pref
If 'prefix' is supplied, use it instead of sys.base_prefix or
sys.base_exec_prefix -- i.e., ignore 'plat_specific'.
"""
@@ -36,7 +39,7 @@ Index: Python-3.3.2/Lib/distutils/sysconfig.py
prefix = plat_specific and BASE_EXEC_PREFIX or BASE_PREFIX
if os.name == "posix":
if python_build:
-@@ -136,6 +139,12 @@
+@@ -134,6 +137,12 @@ def get_python_lib(plat_specific=0, stan
If 'prefix' is supplied, use it instead of sys.base_prefix or
sys.base_exec_prefix -- i.e., ignore 'plat_specific'.
"""
@@ -49,7 +52,7 @@ Index: Python-3.3.2/Lib/distutils/sysconfig.py
if prefix is None:
if standard_lib:
prefix = plat_specific and BASE_EXEC_PREFIX or BASE_PREFIX
-@@ -144,7 +153,7 @@
+@@ -142,7 +151,7 @@ def get_python_lib(plat_specific=0, stan
if os.name == "posix":
libpython = os.path.join(prefix,
@@ -58,16 +61,16 @@ Index: Python-3.3.2/Lib/distutils/sysconfig.py
if standard_lib:
return libpython
else:
-@@ -249,7 +258,7 @@
+@@ -242,7 +251,7 @@ def get_config_h_filename():
else:
- # The name of the config.h file changed in 2.2
- config_h = 'pyconfig.h'
-- return os.path.join(inc_dir, config_h)
-+ return os.path.join(inc_dir, config_h).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
+ inc_dir = get_python_inc(plat_specific=1)
+
+- return os.path.join(inc_dir, 'pyconfig.h')
++ return os.path.join(inc_dir, 'pyconfig.h'.replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") ))
def get_makefile_filename():
-@@ -258,7 +267,7 @@
+@@ -251,7 +260,7 @@ def get_makefile_filename():
return os.path.join(_sys_home or project_base, "Makefile")
lib_dir = get_python_lib(plat_specific=0, standard_lib=1)
config_file = 'config-{}{}'.format(get_python_version(), build_flags)
diff --git a/meta/recipes-devtools/python/python3/avoid-ncursesw-include-path.patch b/meta/recipes-devtools/python/python3/avoid-ncursesw-include-path.patch
index 054a13124c..f29ae53371 100644
--- a/meta/recipes-devtools/python/python3/avoid-ncursesw-include-path.patch
+++ b/meta/recipes-devtools/python/python3/avoid-ncursesw-include-path.patch
@@ -1,29 +1,21 @@
+Upstream-Status: Pending
+
We should make sure that sysroot is used by gcc instead of assuming
hardcoded locations for include paths
-Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-:
-Index: Python-3.3.3/configure.ac
+
+Index: Python-3.4.2/configure.ac
===================================================================
---- Python-3.3.3.orig/configure.ac 2014-01-29 19:00:15.245312752 -0800
-+++ Python-3.3.3/configure.ac 2014-01-29 23:27:22.938526262 -0800
-@@ -1548,7 +1548,7 @@
- # checks for header files
- AC_HEADER_STDC
- ac_save_cppflags="$CPPFLAGS"
--CPPFLAGS="$CPPFLAGS -I/usr/include/ncursesw"
-+CPPFLAGS="$CPPFLAGS -I=/usr/include/ncursesw"
- AC_CHECK_HEADERS(asm/types.h conio.h curses.h direct.h dlfcn.h errno.h \
- fcntl.h grp.h \
- ieeefp.h io.h langinfo.h libintl.h ncurses.h process.h pthread.h \
-@@ -4308,7 +4308,7 @@
- fi
+--- Python-3.4.2.orig/configure.ac
++++ Python-3.4.2/configure.ac
+@@ -4434,7 +4434,7 @@ fi
+ # first curses header check
ac_save_cppflags="$CPPFLAGS"
-CPPFLAGS="$CPPFLAGS -I/usr/include/ncursesw"
+CPPFLAGS="$CPPFLAGS -I=/usr/include/ncursesw"
- # On HP/UX 11.0, mvwdelch is a block with a return statement
- AC_MSG_CHECKING(whether mvwdelch is an expression)
- AC_CACHE_VAL(ac_cv_mvwdelch_is_expression,
+
+ AC_CHECK_HEADERS(curses.h ncurses.h)
+
diff --git a/meta/recipes-devtools/python/python3/python-3.3-multilib.patch b/meta/recipes-devtools/python/python3/python-3.3-multilib.patch
index 7d66a0e00d..b3e986089e 100644
--- a/meta/recipes-devtools/python/python3/python-3.3-multilib.patch
+++ b/meta/recipes-devtools/python/python3/python-3.3-multilib.patch
@@ -1,14 +1,17 @@
+Upstream-Status: Pending
+
get the sys.lib from python itself and do not use hardcoded value of 'lib'
--Khem
+02/2015 Rebased for 3.4.2
-Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
-Index: Python-3.3.2/Include/pythonrun.h
+Index: Python-3.4.2/Include/pythonrun.h
===================================================================
---- Python-3.3.2.orig/Include/pythonrun.h 2013-05-15 09:32:54.000000000 -0700
-+++ Python-3.3.2/Include/pythonrun.h 2013-07-27 16:19:54.099877246 -0700
-@@ -181,6 +181,8 @@
+--- Python-3.4.2.orig/Include/pythonrun.h
++++ Python-3.4.2/Include/pythonrun.h
+@@ -220,6 +220,8 @@ int _Py_CheckPython3();
/* In their own files */
PyAPI_FUNC(const char *) Py_GetVersion(void);
PyAPI_FUNC(const char *) Py_GetPlatform(void);
@@ -17,20 +20,20 @@ Index: Python-3.3.2/Include/pythonrun.h
PyAPI_FUNC(const char *) Py_GetCopyright(void);
PyAPI_FUNC(const char *) Py_GetCompiler(void);
PyAPI_FUNC(const char *) Py_GetBuildInfo(void);
-Index: Python-3.3.2/Lib/distutils/command/install.py
+Index: Python-3.4.2/Lib/distutils/command/install.py
===================================================================
---- Python-3.3.2.orig/Lib/distutils/command/install.py 2013-05-15 09:32:54.000000000 -0700
-+++ Python-3.3.2/Lib/distutils/command/install.py 2013-07-27 16:19:54.099877246 -0700
-@@ -25,6 +25,8 @@
- from site import USER_SITE
- HAS_USER_SITE = True
+--- Python-3.4.2.orig/Lib/distutils/command/install.py
++++ Python-3.4.2/Lib/distutils/command/install.py
+@@ -19,6 +19,8 @@ from site import USER_BASE
+ from site import USER_SITE
+ HAS_USER_SITE = True
+libname = sys.lib
+
- if sys.version < "2.2":
- WINDOWS_SCHEME = {
- 'purelib': '$base',
-@@ -45,7 +47,7 @@
+ WINDOWS_SCHEME = {
+ 'purelib': '$base/Lib/site-packages',
+ 'platlib': '$base/Lib/site-packages',
+@@ -30,7 +32,7 @@ WINDOWS_SCHEME = {
INSTALL_SCHEMES = {
'unix_prefix': {
'purelib': '$base/lib/python$py_version_short/site-packages',
@@ -39,11 +42,11 @@ Index: Python-3.3.2/Lib/distutils/command/install.py
'headers': '$base/include/python$py_version_short$abiflags/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-Index: Python-3.3.2/Lib/pydoc.py
+Index: Python-3.4.2/Lib/pydoc.py
===================================================================
---- Python-3.3.2.orig/Lib/pydoc.py 2013-05-15 09:32:55.000000000 -0700
-+++ Python-3.3.2/Lib/pydoc.py 2013-07-27 16:19:54.103877246 -0700
-@@ -372,7 +372,7 @@
+--- Python-3.4.2.orig/Lib/pydoc.py
++++ Python-3.4.2/Lib/pydoc.py
+@@ -394,7 +394,7 @@ class Doc:
docloc = os.environ.get("PYTHONDOCS", self.PYTHONDOCS)
@@ -52,38 +55,11 @@ Index: Python-3.3.2/Lib/pydoc.py
"python%d.%d" % sys.version_info[:2])
if (isinstance(object, type(os)) and
(object.__name__ in ('errno', 'exceptions', 'gc', 'imp',
-Index: Python-3.3.2/Lib/site.py
-===================================================================
---- Python-3.3.2.orig/Lib/site.py 2013-05-15 09:32:55.000000000 -0700
-+++ Python-3.3.2/Lib/site.py 2013-07-27 16:19:54.103877246 -0700
-@@ -303,13 +303,19 @@
- if sys.platform in ('os2emx', 'riscos'):
- sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
- elif os.sep == '/':
-- sitepackages.append(os.path.join(prefix, "lib",
-+ sitepackages.append(os.path.join(prefix, sys.lib,
- "python" + sys.version[:3],
- "site-packages"))
-- sitepackages.append(os.path.join(prefix, "lib", "site-python"))
-+ if sys.lib != "lib":
-+ sitepackages.append(os.path.join(prefix, "lib",
-+ "python" + sys.version[:3],
-+ "site-packages"))
-+ sitepackages.append(os.path.join(prefix, sys.lib, "site-python"))
-+ if sys.lib != "lib":
-+ sitepackages.append(os.path.join(prefix, "lib", "site-python"))
- else:
- sitepackages.append(prefix)
-- sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
-+ sitepackages.append(os.path.join(prefix, sys.lib, "site-packages"))
- if sys.platform == "darwin":
- # for framework builds *only* we add the standard Apple
- # locations.
-Index: Python-3.3.2/Lib/trace.py
+Index: Python-3.4.2/Lib/trace.py
===================================================================
---- Python-3.3.2.orig/Lib/trace.py 2013-05-15 09:32:56.000000000 -0700
-+++ Python-3.3.2/Lib/trace.py 2013-07-27 16:19:54.103877246 -0700
-@@ -751,10 +751,10 @@
+--- Python-3.4.2.orig/Lib/trace.py
++++ Python-3.4.2/Lib/trace.py
+@@ -751,10 +751,10 @@ def main(argv=None):
# should I also call expanduser? (after all, could use $HOME)
s = s.replace("$prefix",
@@ -96,11 +72,11 @@ Index: Python-3.3.2/Lib/trace.py
"python" + sys.version[:3]))
s = os.path.normpath(s)
ignore_dirs.append(s)
-Index: Python-3.3.2/Makefile.pre.in
+Index: Python-3.4.2/Makefile.pre.in
===================================================================
---- Python-3.3.2.orig/Makefile.pre.in 2013-07-27 16:19:16.000000000 -0700
-+++ Python-3.3.2/Makefile.pre.in 2013-07-27 16:19:54.103877246 -0700
-@@ -96,6 +96,8 @@
+--- Python-3.4.2.orig/Makefile.pre.in
++++ Python-3.4.2/Makefile.pre.in
+@@ -101,6 +101,8 @@ PY_CORE_CFLAGS= $(PY_CFLAGS) $(PY_CFLAGS
# Machine-dependent subdirectories
MACHDEP= @MACHDEP@
@@ -109,7 +85,7 @@ Index: Python-3.3.2/Makefile.pre.in
# Multiarch directory (may be empty)
MULTIARCH= @MULTIARCH@
-@@ -115,7 +117,7 @@
+@@ -120,7 +122,7 @@ LIBDIR= @libdir@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
CONFINCLUDEDIR= $(exec_prefix)/include
@@ -118,7 +94,7 @@ Index: Python-3.3.2/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-@@ -635,6 +637,7 @@
+@@ -712,6 +714,7 @@ Modules/getpath.o: $(srcdir)/Modules/get
-DEXEC_PREFIX='"$(exec_prefix)"' \
-DVERSION='"$(VERSION)"' \
-DVPATH='"$(VPATH)"' \
@@ -126,7 +102,7 @@ Index: Python-3.3.2/Makefile.pre.in
-o $@ $(srcdir)/Modules/getpath.c
Modules/python.o: $(srcdir)/Modules/python.c
-@@ -701,7 +704,7 @@
+@@ -780,7 +783,7 @@ $(AST_C): $(AST_H) $(AST_ASDL) $(ASDLGEN
Python/compile.o Python/symtable.o Python/ast.o: $(GRAMMAR_H) $(AST_H)
Python/getplatform.o: $(srcdir)/Python/getplatform.c
@@ -135,11 +111,11 @@ Index: Python-3.3.2/Makefile.pre.in
Python/importdl.o: $(srcdir)/Python/importdl.c
$(CC) -c $(PY_CORE_CFLAGS) -I$(DLINCLDIR) -o $@ $(srcdir)/Python/importdl.c
-Index: Python-3.3.2/Modules/getpath.c
+Index: Python-3.4.2/Modules/getpath.c
===================================================================
---- Python-3.3.2.orig/Modules/getpath.c 2013-05-15 09:32:59.000000000 -0700
-+++ Python-3.3.2/Modules/getpath.c 2013-07-27 16:19:54.107877246 -0700
-@@ -121,9 +121,11 @@
+--- Python-3.4.2.orig/Modules/getpath.c
++++ Python-3.4.2/Modules/getpath.c
+@@ -117,9 +117,11 @@
#define EXEC_PREFIX PREFIX
#endif
@@ -153,20 +129,19 @@ Index: Python-3.3.2/Modules/getpath.c
#endif
#ifndef LANDMARK
-@@ -135,7 +137,7 @@
+@@ -130,6 +132,7 @@ static wchar_t prefix[MAXPATHLEN+1];
+ static wchar_t exec_prefix[MAXPATHLEN+1];
static wchar_t progpath[MAXPATHLEN+1];
static wchar_t *module_search_path = NULL;
- static int module_search_path_malloced = 0;
--static wchar_t *lib_python = L"lib/python" VERSION;
+static wchar_t *lib_python = L"" LIB_PYTHON;
static void
reduce(wchar_t *dir)
-Index: Python-3.3.2/Python/getplatform.c
+Index: Python-3.4.2/Python/getplatform.c
===================================================================
---- Python-3.3.2.orig/Python/getplatform.c 2013-05-15 09:33:00.000000000 -0700
-+++ Python-3.3.2/Python/getplatform.c 2013-07-27 16:19:54.107877246 -0700
-@@ -10,3 +10,23 @@
+--- Python-3.4.2.orig/Python/getplatform.c
++++ Python-3.4.2/Python/getplatform.c
+@@ -10,3 +10,23 @@ Py_GetPlatform(void)
{
return PLATFORM;
}
@@ -190,11 +165,11 @@ Index: Python-3.3.2/Python/getplatform.c
+{
+ return LIB;
+}
-Index: Python-3.3.2/Python/sysmodule.c
+Index: Python-3.4.2/Python/sysmodule.c
===================================================================
---- Python-3.3.2.orig/Python/sysmodule.c 2013-05-15 09:33:00.000000000 -0700
-+++ Python-3.3.2/Python/sysmodule.c 2013-07-27 16:19:54.107877246 -0700
-@@ -1612,6 +1612,10 @@
+--- Python-3.4.2.orig/Python/sysmodule.c
++++ Python-3.4.2/Python/sysmodule.c
+@@ -1697,6 +1697,10 @@ _PySys_Init(void)
PyUnicode_FromString(Py_GetCopyright()));
SET_SYS_FROM_STRING("platform",
PyUnicode_FromString(Py_GetPlatform()));
@@ -205,11 +180,11 @@ Index: Python-3.3.2/Python/sysmodule.c
SET_SYS_FROM_STRING("executable",
PyUnicode_FromWideChar(
Py_GetProgramFullPath(), -1));
-Index: Python-3.3.2/setup.py
+Index: Python-3.4.2/setup.py
===================================================================
---- Python-3.3.2.orig/setup.py 2013-07-27 16:19:17.000000000 -0700
-+++ Python-3.3.2/setup.py 2013-07-27 16:19:54.107877246 -0700
-@@ -439,7 +439,7 @@
+--- Python-3.4.2.orig/setup.py
++++ Python-3.4.2/setup.py
+@@ -454,7 +454,7 @@ class PyBuildExt(build_ext):
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
if not cross_compiling:
@@ -218,7 +193,7 @@ Index: Python-3.3.2/setup.py
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
# only change this for cross builds for 3.3, issues on Mageia
if cross_compiling:
-@@ -497,8 +497,7 @@
+@@ -512,8 +512,7 @@ class PyBuildExt(build_ext):
# be assumed that no additional -I,-L directives are needed.
if not cross_compiling:
lib_dirs = self.compiler.library_dirs + [
@@ -228,7 +203,7 @@ Index: Python-3.3.2/setup.py
]
inc_dirs = self.compiler.include_dirs + ['/usr/include']
else:
-@@ -675,11 +674,11 @@
+@@ -696,11 +695,11 @@ class PyBuildExt(build_ext):
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -242,11 +217,11 @@ Index: Python-3.3.2/setup.py
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-Index: Python-3.3.2/Lib/sysconfig.py
+Index: Python-3.4.2/Lib/sysconfig.py
===================================================================
---- Python-3.3.2.orig/Lib/sysconfig.py 2013-05-15 09:32:55.000000000 -0700
-+++ Python-3.3.2/Lib/sysconfig.py 2013-07-27 16:19:54.111877246 -0700
-@@ -21,10 +21,10 @@
+--- Python-3.4.2.orig/Lib/sysconfig.py
++++ Python-3.4.2/Lib/sysconfig.py
+@@ -20,10 +20,10 @@ __all__ = [
_INSTALL_SCHEMES = {
'posix_prefix': {
@@ -260,7 +235,7 @@ Index: Python-3.3.2/Lib/sysconfig.py
'include':
'{installed_base}/include/python{py_version_short}{abiflags}',
'platinclude':
-@@ -33,10 +33,10 @@
+@@ -32,10 +32,10 @@ _INSTALL_SCHEMES = {
'data': '{base}',
},
'posix_home': {
@@ -274,7 +249,7 @@ Index: Python-3.3.2/Lib/sysconfig.py
'include': '{installed_base}/include/python',
'platinclude': '{installed_base}/include/python',
'scripts': '{base}/bin',
-@@ -81,10 +81,10 @@
+@@ -61,10 +61,10 @@ _INSTALL_SCHEMES = {
'data': '{userbase}',
},
'posix_user': {
@@ -288,11 +263,11 @@ Index: Python-3.3.2/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-Index: Python-3.3.2/configure.ac
+Index: Python-3.4.2/configure.ac
===================================================================
---- Python-3.3.2.orig/configure.ac 2013-05-15 09:33:00.000000000 -0700
-+++ Python-3.3.2/configure.ac 2013-07-27 16:19:54.111877246 -0700
-@@ -769,6 +769,41 @@
+--- Python-3.4.2.orig/configure.ac
++++ Python-3.4.2/configure.ac
+@@ -791,6 +791,41 @@ esac
MULTIARCH=$($CC --print-multiarch 2>/dev/null)
AC_SUBST(MULTIARCH)
@@ -334,3 +309,30 @@ Index: Python-3.3.2/configure.ac
AC_SUBST(LIBRARY)
AC_MSG_CHECKING(LIBRARY)
+Index: Python-3.4.2/Lib/site.py
+===================================================================
+--- Python-3.4.2.orig/Lib/site.py
++++ Python-3.4.2/Lib/site.py
+@@ -304,13 +304,19 @@ def getsitepackages(prefixes=None):
+ seen.add(prefix)
+
+ if os.sep == '/':
+- sitepackages.append(os.path.join(prefix, "lib",
++ sitepackages.append(os.path.join(prefix, sys.lib,
+ "python" + sys.version[:3],
+ "site-packages"))
+- sitepackages.append(os.path.join(prefix, "lib", "site-python"))
++ if sys.lib != "lib":
++ sitepackages.append(os.path.join(prefix, "lib",
++ "python" + sys.version[:3],
++ "site-packages"))
++ sitepackages.append(os.path.join(prefix, sys.lib, "site-python"))
++ if sys.lib != "lib":
++ sitepackages.append(os.path.join(prefix, sys.lib, "site-python"))
+ else:
+ sitepackages.append(prefix)
+- sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
++ sitepackages.append(os.path.join(prefix, sys.lib, "site-packages"))
+ if sys.platform == "darwin":
+ # for framework builds *only* we add the standard Apple
+ # locations.