aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3/setup.py-find-libraries-in-staging-dirs.patch
diff options
context:
space:
mode:
authorDominic Sacré <dominic.sacre@gmx.de>2015-07-28 16:58:35 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-01 10:59:26 +0100
commit540a223fc0fb6b07dab3316de6236924bd97613c (patch)
treef90039f0c0e013e480a5b9c275d0f0fe6f7a4a4a /meta/recipes-devtools/python/python3/setup.py-find-libraries-in-staging-dirs.patch
parent8e1723eaa4c2dad4d02f7e18d05a1a3239f82ef1 (diff)
downloadopenembedded-core-contrib-540a223fc0fb6b07dab3316de6236924bd97613c.tar.gz
python3: detect libraries in STAGING_LIBDIR
Patch setup.py so that the detect_modules() function looks for required libraries and headers in STAGING_LIBDIR / STAGING_INCDIR. Without this patch, several extension modules are not built, even though their dependencies are present in the compiler's search paths. The result is the following warning, and ultimately incomplete packages: | The necessary bits to build these optional modules were not found: | _bz2 _curses_panel _dbm | _gdbm _lzma _sqlite3 | nis readline zlib | To find the necessary bits, look in setup.py in detect_modules() for the module's name. With the Python 3.3 version of the recipe, at least some of these modules were built, because STAGING_LIBDIR happened to be in the search path by coincidence. Due to changes to distutils in Python 3.4, this is no longer the case. A previous patch that only affects the search paths for SSL is dropped, as this one is a more complete fix for [YOCTO #7768]. Part of the fix for [YOCTO #8048]. Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3/setup.py-find-libraries-in-staging-dirs.patch')
-rw-r--r--meta/recipes-devtools/python/python3/setup.py-find-libraries-in-staging-dirs.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3/setup.py-find-libraries-in-staging-dirs.patch b/meta/recipes-devtools/python/python3/setup.py-find-libraries-in-staging-dirs.patch
new file mode 100644
index 0000000000..f26bd38b02
--- /dev/null
+++ b/meta/recipes-devtools/python/python3/setup.py-find-libraries-in-staging-dirs.patch
@@ -0,0 +1,30 @@
+Patch setup.py so that the detect_modules() function looks for required
+libraries and headers in STAGING_LIBDIR / STAGING_INCDIR.
+
+Without this patch, several extension modules are not built, even though
+their dependencies are present in the compiler's search paths.
+The result is the following warning, and ultimately incomplete packages:
+
+| The necessary bits to build these optional modules were not found:
+| _bz2 _curses_panel _dbm
+| _gdbm _lzma _sqlite3
+| nis readline zlib
+| To find the necessary bits, look in setup.py in detect_modules() for the module's name.
+
+Upstream-Status: Inappropriate [Cross compile specific]
+
+Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de>
+
+Index: Python-3.4.3/setup.py
+===================================================================
+--- Python-3.4.3.orig/setup.py
++++ Python-3.4.3/setup.py
+@@ -521,6 +521,8 @@ class PyBuildExt(build_ext):
+ else:
+ lib_dirs = self.compiler.library_dirs[:]
+ inc_dirs = self.compiler.include_dirs[:]
++ lib_dirs.append(os.environ.get('STAGING_LIBDIR'))
++ inc_dirs.append(os.environ.get('STAGING_INCDIR'))
+ exts = []
+ missing = []
+