summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-10 11:40:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-11 06:54:39 +0000
commitd5d702a2cd06f863340f8e4cdce0904c9d86384d (patch)
tree933a32187ec664ee72a57e6d51474fd5bce2093e /meta/recipes-devtools/python/python3-wheel_0.37.1.bb
parent5d514b5dbd09ce059047d849d5b7cc2b2327564d (diff)
downloadopenembedded-core-contrib-d5d702a2cd06f863340f8e4cdce0904c9d86384d.tar.gz
pip_install_wheel: add a generic do_install for bootstrapping
Several recipes are duplicating the same bootstrap logic for installing a wheel without using any tools. Add an implementation to pip_install_wheel to centralise the code, and remove the duplicated code from the following recipes: - python3-flit-core - python3-pip - python3-setuptools - python3-wheel Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-wheel_0.37.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-wheel_0.37.1.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
index 83a7c986a8..cf0d8191b4 100644
--- a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
+++ b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
@@ -13,9 +13,7 @@ SRC_URI += " file://0001-Backport-pyproject.toml-from-flit-backend-branch.patch"
DEPENDS:remove:class-native = "python3-pip-native"
do_install:class-native () {
- # We need to bootstrap python3-wheel-native
- install -d ${D}${PYTHON_SITEPACKAGES_DIR}
- unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PIP_INSTALL_DIST_PATH}/*.whl
+ pip_install_wheel_do_bootstrap_install
# pip install would normally generate [project.scripts] in ${bindir}
install -d ${D}/${bindir}