summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-webcolors_1.12.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-05-30 14:22:52 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-31 15:23:33 +0100
commita286b1abcc19b6d3e905f1adb09674a87763c49d (patch)
tree01e951903a1b08321f9d5f373d855138eab2af56 /meta/recipes-devtools/python/python3-webcolors_1.12.bb
parent70d68ca81fd92140367a832d7fb30963a2cac5c1 (diff)
downloadopenembedded-core-contrib-a286b1abcc19b6d3e905f1adb09674a87763c49d.tar.gz
python3-webcolors: upgrade 1.11.1 -> 1.12
License-Update: Copyright year updated to 2022 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-webcolors_1.12.bb')
-rw-r--r--meta/recipes-devtools/python/python3-webcolors_1.12.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-webcolors_1.12.bb b/meta/recipes-devtools/python/python3-webcolors_1.12.bb
new file mode 100644
index 0000000000..39ff19c2b8
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-webcolors_1.12.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Simple Python module for working with HTML/CSS color definitions."
+HOMEPAGE = "https://pypi.org/project/webcolors/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bcf737478d2fa8af5bc954231df056c6"
+
+SRC_URI[sha256sum] = "16d043d3a08fd6a1b1b7e3e9e62640d09790dce80d2bdd4792a175b35fe794a9"
+
+inherit pypi setuptools3 ptest
+
+RDEPENDS:${PN}:class-target = "\
+ ${PYTHON_PN}-stringold \
+"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"