summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-wcwidth_0.2.5.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 20:24:23 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-30 14:40:55 +0000
commite7b8f091733cb163a0fffed265c6d88b5f0cfae2 (patch)
treeb07e65bc1237ff7fb7700b6381a777f6295f4c05 /meta/recipes-devtools/python/python3-wcwidth_0.2.5.bb
parentc1aa2915bb16d7db4ade38b0cf107917aab09644 (diff)
downloadopenembedded-core-contrib-e7b8f091733cb163a0fffed265c6d88b5f0cfae2.tar.gz
python3-wcwidth: move from meta-python
Library for bulding powerful interactive command lines in Python * Part of the dependency chain for pytest Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-wcwidth_0.2.5.bb')
-rw-r--r--meta/recipes-devtools/python/python3-wcwidth_0.2.5.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-wcwidth_0.2.5.bb b/meta/recipes-devtools/python/python3-wcwidth_0.2.5.bb
new file mode 100644
index 0000000000..bb4aae2e86
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-wcwidth_0.2.5.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Library for building powerful interactive command lines in Python"
+DESCRIPTION = "Measures the displayed width of unicode strings in a terminal"
+HOMEPAGE = "https://github.com/jquast/wcwidth"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b15979c39a2543892fca8cd86b4b52cb"
+
+SRC_URI[md5sum] = "a07a75f99d316e14838ac760c831ea37"
+SRC_URI[sha256sum] = "c4d647b99872929fdb7bdcaa4fbe7f01413ed3d98077df798530e5b04f116c83"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"