aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_38.2.4.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-18 15:57:29 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-13 13:59:44 +0000
commit624a6f209248a0c8e0759d43f246c903a8db6a71 (patch)
treea842ab24dd7a696d3f57106aa2fe7c0d1e1e8bad /meta/recipes-devtools/python/python3-setuptools_38.2.4.bb
parentd95f1005c35bd9c7e22c40c7c17d264fe9435c6b (diff)
downloadopenembedded-core-contrib-624a6f209248a0c8e0759d43f246c903a8db6a71.tar.gz
python-setuptools: upgrade to 38.2.4; use pypi.bbclass; improvements
* Simplify python- and python3-setuptools with pypi.bbclass * inherit setuptools rather than distutils * Consolidate common settings in python-setuptools.inc - use PYTHON_PN variable to eliminate duplication - python3-setuptools had missing RDEPENDS (e.g., plistlib) - installer no longer creates setuptools.pth, drop fixes Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_38.2.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_38.2.4.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_38.2.4.bb b/meta/recipes-devtools/python/python3-setuptools_38.2.4.bb
new file mode 100644
index 0000000000..0dc1ed8622
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_38.2.4.bb
@@ -0,0 +1,6 @@
+require python-setuptools.inc
+inherit setuptools3
+
+do_install_append() {
+ mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
+}