aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-18 15:57:29 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-13 13:59:44 +0000
commit624a6f209248a0c8e0759d43f246c903a8db6a71 (patch)
treea842ab24dd7a696d3f57106aa2fe7c0d1e1e8bad /meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
parentd95f1005c35bd9c7e22c40c7c17d264fe9435c6b (diff)
downloadopenembedded-core-contrib-624a6f209248a0c8e0759d43f246c903a8db6a71.tar.gz
python-setuptools: upgrade to 38.2.4; use pypi.bbclass; improvements
* Simplify python- and python3-setuptools with pypi.bbclass * inherit setuptools rather than distutils * Consolidate common settings in python-setuptools.inc - use PYTHON_PN variable to eliminate duplication - python3-setuptools had missing RDEPENDS (e.g., plistlib) - installer no longer creates setuptools.pth, drop fixes Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_36.5.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_36.5.0.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb b/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
deleted file mode 100644
index 63f241809e..0000000000
--- a/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
+++ /dev/null
@@ -1,38 +0,0 @@
-require python-setuptools.inc
-
-DEPENDS += "python3"
-DEPENDS_class-native += "python3-native"
-DEPENDS_class-nativesdk += "nativesdk-python3"
-
-inherit distutils3
-
-DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
-
-# The installer puts the wrong path in the setuptools.pth file. Correct it.
-do_install_append() {
- rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
- mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
- echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
-}
-
-RDEPENDS_${PN}_class-native = "\
- python3-distutils \
- python3-compression \
-"
-RDEPENDS_${PN} = "\
- python3-ctypes \
- python3-distutils \
- python3-email \
- python3-importlib \
- python3-numbers \
- python3-compression \
- python3-shell \
- python3-subprocess \
- python3-textutils \
- python3-pkgutil \
- python3-threading \
- python3-misc \
- python3-unittest \
- python3-xml \
-"
-BBCLASSEXTEND = "native nativesdk"