aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_29.0.1.bb
diff options
context:
space:
mode:
authorEdwin Plauchu <edwin.plauchu.camacho@intel.com>2016-11-30 14:34:32 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-07 10:36:11 +0000
commitf0c75fecdf15453c5fb252eb9f3de3ea9ce5169b (patch)
tree838c06e51a1805577f441f70501830fd0c170d16 /meta/recipes-devtools/python/python3-setuptools_29.0.1.bb
parentb645919f173512f9e75aeb26348d60b63dcdc53c (diff)
downloadopenembedded-core-contrib-f0c75fecdf15453c5fb252eb9f3de3ea9ce5169b.tar.gz
python3-setuptools: upgrade to 29.0.1
It is a simultaneous upgrade for python 2 and 3 over setuptools. Signed-off-by: Edwin Plauchu <edwin.plauchu.camacho@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_29.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_29.0.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_29.0.1.bb b/meta/recipes-devtools/python/python3-setuptools_29.0.1.bb
new file mode 100644
index 0000000000..65af6f0dad
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_29.0.1.bb
@@ -0,0 +1,37 @@
+require python-setuptools.inc
+
+DEPENDS += "python3"
+DEPENDS_class-native += "python3-native"
+
+inherit distutils3
+
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
+
+# The installer puts the wrong path in the setuptools.pth file. Correct it.
+do_install_append() {
+ rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
+ mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
+ echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
+}
+
+RDEPENDS_${PN} = "\
+ python3-distutils \
+ python3-compression \
+"
+RDEPENDS_${PN}_class-target = "\
+ python3-ctypes \
+ python3-distutils \
+ python3-email \
+ python3-importlib \
+ python3-numbers \
+ python3-compression \
+ python3-shell \
+ python3-subprocess \
+ python3-textutils \
+ python3-pkgutil \
+ python3-threading \
+ python3-misc \
+ python3-unittest \
+ python3-xml \
+"
+BBCLASSEXTEND = "native"