summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools-scm_6.4.2.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-01-24 11:49:07 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-26 06:25:33 +0000
commit3ac37c743470ab778bc47110660f3e1b37c534ba (patch)
treea6b3a44a4c2056af204c6ae32b6a640b2673c464 /meta/recipes-devtools/python/python3-setuptools-scm_6.4.2.bb
parent5044bb45748887b01e857554976fe1eeb16921dd (diff)
downloadopenembedded-core-contrib-3ac37c743470ab778bc47110660f3e1b37c534ba.tar.gz
python3-setuptools-scm: upgrade 6.3.2 -> 6.4.2
v6.4.2 * fix #671 : NoReturn is not avaliable in painfully dead python 3.6 v6.4.1 * fix regression #669: restore get_version signature * fix #668: harden the selftest for distribution extras v6.4.0 * compatibility adjustments for setuptools >58 * only put minimal setuptools version into toml extra to warn people with old strict pins * coorectly handle hg-git self-use * better mercurial detection * modernize packaging setup * python 3.10 support * better handling of setuptools install command deprecation * consider pyproject.tomls when running as command * use list in git describe command to avoid shell expansions while supporting both windows and posix * add --strip-dev flag to python -m setuptools_scm to print the next guessed version cleanly * ensure no-guess-dev will fail on bad tags instead of generating invalid versions * ensure we use utc everywhere to avoid confusion References: https://github.com/pypa/setuptools_scm/issues/668 https://github.com/pypa/setuptools_scm/issues/669 https://github.com/pypa/setuptools_scm/issues/671 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools-scm_6.4.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools-scm_6.4.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools-scm_6.4.2.bb b/meta/recipes-devtools/python/python3-setuptools-scm_6.4.2.bb
new file mode 100644
index 0000000000..10dad5a37b
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools-scm_6.4.2.bb
@@ -0,0 +1,26 @@
+SUMMARY = "the blessed package to manage your versions by scm tags"
+HOMEPAGE = "https://pypi.org/project/setuptools-scm/"
+DESCRIPTION = "setuptools_scm handles managing your Python package versions in SCM metadata instead of declaring them as the version argument or in a SCM managed file."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[sha256sum] = "6833ac65c6ed9711a4d5d2266f8024cfa07c533a0e55f4c12f6eff280a5a9e30"
+
+PYPI_PACKAGE = "setuptools_scm"
+inherit pypi setuptools3
+
+UPSTREAM_CHECK_REGEX = "setuptools_scm-(?P<pver>.*)\.tar"
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-packaging \
+ ${PYTHON_PN}-pyparsing \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-tomli \
+"
+
+RDEPENDS:${PN}:append:class-target = " \
+ ${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-json \
+"
+
+BBCLASSEXTEND = "native nativesdk"