summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools-rust_1.4.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-07-20 10:44:33 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-07-23 13:55:13 +0100
commitfbb468411d9d67b32b6e7e66f8d591cbf20098f9 (patch)
treea3823f160831dacbae9067415af84b196cd793c1 /meta/recipes-devtools/python/python3-setuptools-rust_1.4.1.bb
parent525420a90d9c136f379cb85e9e0898fc40e4805f (diff)
downloadopenembedded-core-contrib-fbb468411d9d67b32b6e7e66f8d591cbf20098f9.tar.gz
python3-setuptools-rust: upgrade 1.3.0 -> 1.4.1
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools-rust_1.4.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools-rust_1.4.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools-rust_1.4.1.bb b/meta/recipes-devtools/python/python3-setuptools-rust_1.4.1.bb
new file mode 100644
index 0000000000..c63a3f2b52
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools-rust_1.4.1.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Setuptools Rust extension plugin"
+DESCRIPTION = "setuptools-rust is a plugin for setuptools to build Rust \
+Python extensions implemented with PyO3 or rust-cpython.\
+\
+Compile and distribute Python extensions written in Rust as easily as if they were written in C."
+HOMEPAGE = "https://github.com/PyO3/setuptools-rust"
+BUGTRACKER = "https://github.com/PyO3/setuptools-rust/issues"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5"
+
+SRC_URI = "https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz \
+ file://8e9892f08b1248dc03862da86915c2745e0ff7ec.patch"
+SRC_URI[sha256sum] = "18ff850831f58ee21d5783825c99fad632da21e47645e9427fd7dec048029e76"
+
+inherit cargo pypi python_setuptools_build_meta
+
+DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
+
+RDEPENDS:${PN}:class-native += " \
+ python3-semantic-version-native \
+ python3-setuptools-native \
+ python3-setuptools-scm-native \
+ python3-toml-native \
+ python3-typing-extensions-native \
+ python3-wheel-native \
+"
+
+BBCLASSEXTEND = "native"