summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pyyaml_6.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-10-20 18:57:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-23 17:41:46 +0100
commit2abc7a612a71b3594f3183fbb824a708269ae694 (patch)
treed0971344829e3534513c30ca6307d1f92842d5a5 /meta/recipes-devtools/python/python3-pyyaml_6.0.bb
parentf6fb99c53f779966fc902a629d0a8bbd9f84c6be (diff)
downloadopenembedded-core-contrib-2abc7a612a71b3594f3183fbb824a708269ae694.tar.gz
python3-pyyaml: upgrade 5.4.1 -> 6.0
Now uses "vendored" distutils from setuptools by default rather than from Python stdlib. Changes ======= * https://github.com/yaml/pyyaml/pull/327 -- Change README format to Markdown * https://github.com/yaml/pyyaml/pull/483 -- Add a test for YAML 1.1 types * https://github.com/yaml/pyyaml/pull/497 -- fix float resolver to ignore `.` and `._` * https://github.com/yaml/pyyaml/pull/550 -- drop Python 2.7 * https://github.com/yaml/pyyaml/pull/553 -- Fix spelling of “hexadecimal” * https://github.com/yaml/pyyaml/pull/556 -- fix representation of Enum subclasses * https://github.com/yaml/pyyaml/pull/557 -- fix libyaml extension compiler warnings * https://github.com/yaml/pyyaml/pull/560 -- fix ResourceWarning on leaked file descriptors * https://github.com/yaml/pyyaml/pull/561 -- always require `Loader` arg to `yaml.load()` * https://github.com/yaml/pyyaml/pull/564 -- remove remaining direct distutils usage Signed-off-by: Tim Orling <timothy.t.orling@intel.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pyyaml_6.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pyyaml_6.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pyyaml_6.0.bb b/meta/recipes-devtools/python/python3-pyyaml_6.0.bb
new file mode 100644
index 0000000000..2df0e649f0
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pyyaml_6.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Python support for YAML"
+DEPENDS += "libyaml ${PYTHON_PN}-cython-native"
+HOMEPAGE = "https://pyyaml.org/"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6d8242660a8371add5fe547adf083079"
+
+PYPI_PACKAGE = "PyYAML"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "68fb519c14306fec9720a2a5b45bc9f0c8d1b9c72adf45c37baedfcd949c35a2"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-netclient \
+"
+
+BBCLASSEXTEND = "native nativesdk"