aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pygobject_3.26.1.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-22 12:19:17 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-02 17:24:16 +0000
commit01610f3ba7c62afdfab118e8cf44c3c1c900ba57 (patch)
tree2b557915c022599deb3caa2460a167170499f053 /meta/recipes-devtools/python/python3-pygobject_3.26.1.bb
parent8c3eb79d91351bba8be0eadb3cce60b8327fc232 (diff)
downloadopenembedded-core-contrib-01610f3ba7c62afdfab118e8cf44c3c1c900ba57.tar.gz
python3-pygobject: update to 3.26.1
Update to the latest stable release Tested in qemux86-64 running core-image-minimal Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pygobject_3.26.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.26.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.26.1.bb b/meta/recipes-devtools/python/python3-pygobject_3.26.1.bb
new file mode 100644
index 0000000000..0405b44f17
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pygobject_3.26.1.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Python GObject bindings"
+SECTION = "devel/python"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
+
+inherit autotools pkgconfig gnomebase distutils3-base gobject-introspection upstream-version-is-even
+
+DEPENDS += "python3 glib-2.0"
+
+SRCNAME="pygobject"
+SRC_URI = " \
+ http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
+"
+
+SRC_URI[md5sum] = "d898fc768ebec7a9ed4e4270c6fabfde"
+SRC_URI[sha256sum] = "f5577b9b9c70cabb9a60d81b855d488b767c66f867432e7fb64aa7269b04d1a9"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+
+PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"
+
+# python3-pycairo is checked on configuration -> DEPENDS
+# we don't link against python3-pycairo -> RDEPENDS
+PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo"
+
+RDEPENDS_${PN} += "python3-setuptools python3-importlib"
+
+BBCLASSEXTEND = "native"
+PACKAGECONFIG_class-native = ""