summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pluggy_0.13.1.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 15:57:47 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 16:23:45 -0800
commit17ca5e6a689fcdc32b0467a500b53d8719afd1d4 (patch)
tree6c8d40f0208cfa1c519ddec40568419c1c73376b /meta/recipes-devtools/python/python3-pluggy_0.13.1.bb
parent8c61a338dfed0b50bf133ddbf6f1e0246b01e8cc (diff)
downloadopenembedded-core-contrib-17ca5e6a689fcdc32b0467a500b53d8719afd1d4.tar.gz
python3-pluggy: move from meta-python
Plugin and hook calling mechanisms for python * Part of the dependency chain for pytest Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pluggy_0.13.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pluggy_0.13.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pluggy_0.13.1.bb b/meta/recipes-devtools/python/python3-pluggy_0.13.1.bb
new file mode 100644
index 0000000000..d3e0365ca1
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pluggy_0.13.1.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Plugin and hook calling mechanisms for python"
+HOMEPAGE = "https://github.com/pytest-dev/pluggy"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2"
+
+SRC_URI[md5sum] = "7f610e28b8b34487336b585a3dfb803d"
+SRC_URI[sha256sum] = "15b2acde666561e1298d71b523007ed7364de07029219b604cf808bfa1c765b0"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-importlib-metadata \
+ ${PYTHON_PN}-more-itertools \
+"
+
+inherit pypi ptest setuptools3
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/testing
+ cp -rf ${S}/testing/* ${D}${PTEST_PATH}/testing/
+}