aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_8.1.2.bb
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2016-08-09 10:01:41 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-17 10:33:32 +0100
commite7d842673952aa4aaa141f64958bc1344dbe8210 (patch)
treec80d7dcd76364c1f27c3f96e4bc2a122bbea6dc1 /meta/recipes-devtools/python/python3-pip_8.1.2.bb
parent9f9240d175acee274c04242fd5781094b3f5491b (diff)
downloadopenembedded-core-contrib-e7d842673952aa4aaa141f64958bc1344dbe8210.tar.gz
Use PYTHON_SITEPACKAGES_DIR insted of hard-coded *site-packages*
For thoese recipes that are inheriting python*-dir.bbclass, there is already a PYTHON_SITEPACKAGES_DIR present, use that definition replacing redundant "${libdir}/python*/site-packages". Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_8.1.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_8.1.2.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_8.1.2.bb b/meta/recipes-devtools/python/python3-pip_8.1.2.bb
index e319dff675..eefb4cb796 100644
--- a/meta/recipes-devtools/python/python3-pip_8.1.2.bb
+++ b/meta/recipes-devtools/python/python3-pip_8.1.2.bb
@@ -18,16 +18,16 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils3
-DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
do_install_prepend() {
- install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}
}
# Use setuptools site.py instead, avoid shared state issue
do_install_append() {
- rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/site.py
- rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/__pycache__/site.cpython-*.pyc
+ rm ${D}${PYTHON_SITEPACKAGES_DIR}/site.py
+ rm ${D}${PYTHON_SITEPACKAGES_DIR}/__pycache__/site.cpython-*.pyc
# Install as pip3 and leave pip2 as default
rm ${D}/${bindir}/pip