summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_18.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-08-17 08:25:42 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-20 11:59:44 +0100
commit30d0e8e895813bc422d60bd00076a7f16035feeb (patch)
tree0f81b2199e5c5dfba10c1c666b2fb1960c500dc8 /meta/recipes-devtools/python/python3-pip_18.0.bb
parentd39bf67b8c6d80562d35fc8d8f72d26f77cc451e (diff)
downloadopenembedded-core-contrib-30d0e8e895813bc422d60bd00076a7f16035feeb.tar.gz
python3-pip: update to version 18.0
License-Update: Update checksum for copyright year changes Update to the latest stable version Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_18.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_18.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_18.0.bb b/meta/recipes-devtools/python/python3-pip_18.0.bb
new file mode 100644
index 0000000000..3fcdb8014a
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_18.0.bb
@@ -0,0 +1,30 @@
+SUMMARY = "The PyPA recommended tool for installing Python packages"
+HOMEPAGE = "https://pypi.python.org/pypi/pip"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=593c6cd9d639307226978cbcae61ad4b"
+
+DEPENDS += "python3 python3-setuptools-native"
+
+SRC_URI[md5sum] = "52f75ceb21e96c258f289859a2996b60"
+SRC_URI[sha256sum] = "a0e11645ee37c90b40c46d607070c4fd583e2cd46231b1c06e389c5e814eed76"
+
+inherit pypi distutils3
+
+do_install_append() {
+ # Install as pip3 and leave pip2 as default
+ rm ${D}/${bindir}/pip
+}
+
+RDEPENDS_${PN} = "\
+ python3-compile \
+ python3-io \
+ python3-html \
+ python3-json \
+ python3-netserver \
+ python3-setuptools \
+ python3-unixadmin \
+ python3-xmlrpc \
+"
+
+BBCLASSEXTEND = "native nativesdk"