summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-magic_0.4.26.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-05-25 14:45:30 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-27 23:47:20 +0100
commit4f4483a5e9df585d74071d30a52fd5839d320828 (patch)
tree4f90dbf669c8cc47ed8e42340b5ad97ecf4ae616 /meta/recipes-devtools/python/python3-magic_0.4.26.bb
parent372c0db2d7f661317ab57618e4707069450313cb (diff)
downloadopenembedded-core-contrib-4f4483a5e9df585d74071d30a52fd5839d320828.tar.gz
python3-magic: upgrade 0.4.25 -> 0.4.26
Changes to 0.4.26: - Use tox for all multi-version testing - Fix use of pytest, use it via tox Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-magic_0.4.26.bb')
-rw-r--r--meta/recipes-devtools/python/python3-magic_0.4.26.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-magic_0.4.26.bb b/meta/recipes-devtools/python/python3-magic_0.4.26.bb
new file mode 100644
index 0000000000..89495ecc7c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-magic_0.4.26.bb
@@ -0,0 +1,22 @@
+SUMMARY = "File type identification using libmagic"
+DESCRIPTION = "This module uses ctypes to access the libmagic file type \
+ identification library. It makes use of the local magic database and supports \
+ both textual and MIME-type output."
+HOMEPAGE = "http://github.com/ahupp/python-magic"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=61495c152d794e6be5799a9edca149e3"
+
+PYPI_PACKAGE = "python-magic"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "8262c13001f904ad5b724d38b5e5b5f17ec0450ae249def398a62e4e33108a50"
+
+RDEPENDS:${PN} += "file \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-shell"
+
+BBCLASSEXTEND = "native"