summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-magic_0.4.18.bb
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2020-05-21 10:23:20 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-24 23:55:31 +0100
commite8446a7c9af325be952f8edaef5a299b556ac635 (patch)
tree37f542c17675082a455ed95cfbc98a646567ecd4 /meta/recipes-devtools/python/python3-magic_0.4.18.bb
parent75e89667c973c18a9794167cb5c357f6464cc63a (diff)
downloadopenembedded-core-contrib-e8446a7c9af325be952f8edaef5a299b556ac635.tar.gz
python3-magic: upgrade 0.4.15 -> 0.4.18
Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-magic_0.4.18.bb')
-rw-r--r--meta/recipes-devtools/python/python3-magic_0.4.18.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-magic_0.4.18.bb b/meta/recipes-devtools/python/python3-magic_0.4.18.bb
new file mode 100644
index 0000000000..be423adacd
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-magic_0.4.18.bb
@@ -0,0 +1,19 @@
+SUMMARY = "File type identification using libmagic"
+DESCRIPTION = "This module uses ctypes to access the libmagic file type \
+ identification library. It makes use of the local magic database and supports \
+ both textual and MIME-type output."
+HOMEPAGE = "http://github.com/ahupp/python-magic"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=16a934f165e8c3245f241e77d401bb88"
+
+PYPI_PACKAGE = "python-magic"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "5edc6caa39cc62641850f6b1b6f284ba"
+SRC_URI[sha256sum] = "b757db2a5289ea3f1ced9e60f072965243ea43a2221430048fd8cacab17be0ce"
+
+RDEPENDS_${PN} += "file"
+
+BBCLASSEXTEND = "native"