summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-libarchive-c_4.0.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-01-25 08:11:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-26 06:25:33 +0000
commit9adbc075c5a2b396d991144596fd92ebe16d4154 (patch)
treec579401ad0a188d6cb855eaa176b7faa5acaf305 /meta/recipes-devtools/python/python3-libarchive-c_4.0.bb
parent170ba2ab0733d781a95d8120fdfe9eccacee8b89 (diff)
downloadopenembedded-core-contrib-9adbc075c5a2b396d991144596fd92ebe16d4154.tar.gz
python3-libarchive-c: upgrade 3.2 -> 4.0
Changelog: ========= -BREAKING & SECURITY: The archive extraction functions now pass 3 security flags (SECURE_NODOTDOT, SECURE_NOABSOLUTEPATHS and SECURE_SYMLINKS) to libarchive by default, unless the current directory is the root. -BREAKING: The ArchiveEntry properties atime, mtime, ctime, birthtime and size now have the value None instead of 0 when they're unset. -BREAKING: The ArchiveEntry.pathname property now attempts to decode bytes using UTF-8. This breaks reading archives that contain file names which look like UTF-8 but aren't, if such a thing exists. Proper support of encodings will probably be added in the next version. -Multiple entries from the same archive can now be kept in memory, however only the current entry's content can be read. -The filetype, linkpath, size, mode, redvmajor, redvminor, uid and gid attributes of an archive entry can now be modified. -The four time properties of archive entries now have setters, so for example entry.set_mtime(0, 0) can be replaced by entry.mtime = 0. -Archive entries have 4 new properties: perm, rdev, uname and gname. -When adding files to an archive, a destination path can now be specified. -The ArchiveRead class now has a bytes_read property. -The ArchiveWrite class now has a bytes_written property. -Python 3.6 is no longer tested. -The documentation has been improved. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-libarchive-c_4.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-libarchive-c_4.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-libarchive-c_4.0.bb b/meta/recipes-devtools/python/python3-libarchive-c_4.0.bb
new file mode 100644
index 0000000000..3c6bc1e1ca
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-libarchive-c_4.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Python interface to libarchive"
+DESCRIPTION = "A Python interface to libarchive. It uses the standard ctypes module to \
+ dynamically load and access the C library."
+HOMEPAGE = "https://github.com/Changaco/python-libarchive-c"
+LICENSE = "CC0-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=bcab380227a83bc147350b40a81e6ffc"
+
+PYPI_PACKAGE = "libarchive-c"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "a5b41ade94ba58b198d778e68000f6b7de41da768de7140c984f71d7fa8416e5"
+
+RDEPENDS:${PN} += "\
+ libarchive \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-mmap \
+ ${PYTHON_PN}-logging \
+"
+
+BBCLASSEXTEND = "native"