summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-iso8601_1.1.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-10-08 16:54:53 -0700
committerAlexandre Belloni <alexandre.belloni@bootlin.com>2022-10-25 14:51:54 +0200
commite459e5e91d2ed56dc2c75ed1e1a984a7b99dfcd8 (patch)
treedb03923d256134f3d3696ba56a368a417c061c08 /meta/recipes-devtools/python/python3-iso8601_1.1.0.bb
parent0cf8aeea74205b71be633afb199bf7ce5afbc938 (diff)
downloadopenembedded-core-contrib-e459e5e91d2ed56dc2c75ed1e1a984a7b99dfcd8.tar.gz
python3-iso8601: upgrade 1.0.2 -> 1.1.0
e3b4ed3 Release 1.1.0 56da11c missed a comma fde429d raise ParseError if we get an exception on is_iso8601() 21f5368 Add is_iso8601() function 406db6f Update license years License-Update: copyright years updated. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-iso8601_1.1.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-iso8601_1.1.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-iso8601_1.1.0.bb b/meta/recipes-devtools/python/python3-iso8601_1.1.0.bb
new file mode 100644
index 0000000000..797607f81e
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-iso8601_1.1.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Simple module to parse ISO 8601 dates"
+HOMEPAGE = "http://pyiso8601.readthedocs.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=aab31f2ef7ba214a5a341eaa47a7f367"
+
+SRC_URI[sha256sum] = "32811e7b81deee2063ea6d2e94f8819a86d1f3811e49d23623a41fa832bef03f"
+
+inherit pypi python_poetry_core
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-numbers \
+"
+
+BBCLASSEXTEND = "native nativesdk"